summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 20:35:57 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 20:35:57 +0000
commit6e74435165e35638a60d526ba4e9e355e1f8e363 (patch)
tree7b320ce05ec62cf3918687f082a1d9800af0f3b6 /app-misc/wipe
parentQA: Respect CC (bug 243680) (diff)
downloadgentoo-2-6e74435165e35638a60d526ba4e9e355e1f8e363.tar.gz
gentoo-2-6e74435165e35638a60d526ba4e9e355e1f8e363.tar.bz2
gentoo-2-6e74435165e35638a60d526ba4e9e355e1f8e363.zip
QA: Respect CC (bug 243682), respect CFLAGS (bug 240083)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-misc/wipe')
-rw-r--r--app-misc/wipe/ChangeLog8
-rw-r--r--app-misc/wipe/wipe-2.2.20050509.ebuild12
2 files changed, 14 insertions, 6 deletions
diff --git a/app-misc/wipe/ChangeLog b/app-misc/wipe/ChangeLog
index c920512af3e2..8b384a90ca32 100644
--- a/app-misc/wipe/ChangeLog
+++ b/app-misc/wipe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/wipe
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.20 2007/12/07 17:00:29 dertobi123 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/ChangeLog,v 1.21 2008/12/30 20:35:57 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org>
+ wipe-2.2.20050509.ebuild:
+ QA: Respect CC (bug 243682), respect CFLAGS (bug 240083)
07 Dec 2007; Tobias Scherbaum <dertobi123@gentoo.org>
wipe-2.2.20050509.ebuild:
diff --git a/app-misc/wipe/wipe-2.2.20050509.ebuild b/app-misc/wipe/wipe-2.2.20050509.ebuild
index 8bcd43b69bba..9095ead47215 100644
--- a/app-misc/wipe/wipe-2.2.20050509.ebuild
+++ b/app-misc/wipe/wipe-2.2.20050509.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.2.20050509.ebuild,v 1.6 2007/12/07 17:00:29 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.2.20050509.ebuild,v 1.7 2008/12/30 20:35:57 angelos Exp $
-inherit versionator
+inherit versionator toolchain-funcs
MY_PV=$(get_version_component_range 3)
MY_SRC=${PN}-wip-${MY_PV}
@@ -17,7 +17,11 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-DEPEND=""
+src_compile() {
+ econf
+ sed -i -e "s:-pipe -O2:${CFLAGS}:" "${S}"/Makefile || die "sed failed"
+ emake CC="$(tc-getCC)" || die emake failed
+}
src_install() {
dobin wipe || die "dobin failed"