summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-02-25 15:33:42 +0000
committerAlex Alexander <wired@gentoo.org>2012-02-25 15:33:42 +0000
commitff23339e420ff31230cfe66771c349ffe75df211 (patch)
tree05477ba8186a48e379a66710b1b7532e25c2f1a4 /app-misc/vifm
parentOld. (diff)
downloadgentoo-2-ff23339e420ff31230cfe66771c349ffe75df211.tar.gz
gentoo-2-ff23339e420ff31230cfe66771c349ffe75df211.tar.bz2
gentoo-2-ff23339e420ff31230cfe66771c349ffe75df211.zip
version bump, bug #405305
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/vifm')
-rw-r--r--app-misc/vifm/ChangeLog9
-rw-r--r--app-misc/vifm/vifm-0.7.2.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/app-misc/vifm/ChangeLog b/app-misc/vifm/ChangeLog
index a78faa18c97e..8ef9fd273348 100644
--- a/app-misc/vifm/ChangeLog
+++ b/app-misc/vifm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/vifm
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/ChangeLog,v 1.21 2011/11/24 22:03:54 wired Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/ChangeLog,v 1.22 2012/02/25 15:33:42 wired Exp $
+
+*vifm-0.7.2 (25 Feb 2012)
+
+ 25 Feb 2012; Alex Alexander <wired@gentoo.org> +vifm-0.7.2.ebuild:
+ version bump, bug #405305
*vifm-0.7.1 (24 Nov 2011)
diff --git a/app-misc/vifm/vifm-0.7.2.ebuild b/app-misc/vifm/vifm-0.7.2.ebuild
new file mode 100644
index 000000000000..4a747d6a0c8f
--- /dev/null
+++ b/app-misc/vifm/vifm-0.7.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.7.2.ebuild,v 1.1 2012/02/25 15:33:42 wired Exp $
+
+EAPI=4
+inherit base
+
+DESCRIPTION="Console file manager with vi(m)-like keybindings"
+HOMEPAGE="http://vifm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vifm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE="+compatibility +extended-keys +magic vim-plugin vim-syntax"
+
+DEPEND="
+ >=sys-libs/ncurses-5.7-r7
+ magic? ( sys-apps/file )
+"
+RDEPEND="
+ ${DEPEND}
+ vim-plugin? ( >=app-editors/vim-7.3 )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+DOCS=( AUTHORS TODO README )
+
+S="${WORKDIR}"
+
+src_configure() {
+ econf \
+ $(use_enable compatibility compatibility-mode) \
+ $(use_enable extended-keys) \
+ $(use_with magic libmagic)
+}
+
+src_install() {
+ base_src_install
+
+ if use vim-syntax; then
+ local t
+ for t in ftdetect ftplugin syntax; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/"${t}"/"${PN}".vim
+ done
+ fi
+ if use vim-plugin; then
+ local t
+ for t in doc plugin; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/"${t}"/"${PN}".*
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "To use vim to view the vifm help, copy /usr/share/${P}/vifm.txt"
+ elog " to ~/.vim/doc/ and run ':helptags ~/.vim/doc' in vim,"
+ elog "then edit ~/.vifm/vifmrc${PV/a/} and set USE_VIM_HELP=1"
+ elog ""
+ elog "To use the vifm plugin in vim, copy /usr/share/${P}/vifm.vim to"
+ elog " /usr/share/vim/vimXX/"
+}