summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-07-06 09:54:30 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-07-06 09:54:30 +0000
commitc950e25c82debb78878fd1e6f1f52e59775e00e8 (patch)
tree3b261da72ad689a1acef60749a5177f95c99cbfe /app-misc/usbirboy
parentAdded a block on eselect-1.0.3 for eselect-opengl-1.0.3. Bumped to eselect-op... (diff)
downloadgentoo-2-c950e25c82debb78878fd1e6f1f52e59775e00e8.tar.gz
gentoo-2-c950e25c82debb78878fd1e6f1f52e59775e00e8.tar.bz2
gentoo-2-c950e25c82debb78878fd1e6f1f52e59775e00e8.zip
Added a patch to remove absolute filenames from printk statements.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'app-misc/usbirboy')
-rw-r--r--app-misc/usbirboy/ChangeLog6
-rw-r--r--app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff48
-rw-r--r--app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild3
3 files changed, 55 insertions, 2 deletions
diff --git a/app-misc/usbirboy/ChangeLog b/app-misc/usbirboy/ChangeLog
index 3d07c2df10bb..e825ada70925 100644
--- a/app-misc/usbirboy/ChangeLog
+++ b/app-misc/usbirboy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/usbirboy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/ChangeLog,v 1.5 2006/07/03 08:39:09 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/ChangeLog,v 1.6 2006/07/06 09:54:30 zzam Exp $
+
+ 06 Jul 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/usbirboy-0.2.1-nice-kernel-msgs.diff, usbirboy-0.2.1-r1.ebuild:
+ Added a patch to remove absolute filenames from printk statements.
03 Jul 2006; Matthias Schwarzott <zzam@gentoo.org>
+files/usbirboy-0.2.1-module_param.diff, -usbirboy-0.2.1.ebuild,
diff --git a/app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff b/app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff
new file mode 100644
index 000000000000..8cac30623f9c
--- /dev/null
+++ b/app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff
@@ -0,0 +1,48 @@
+diff -ru usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c usbirboy-0.2.1/usbirboykmod/usbirboy.c
+--- usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c 2006-07-06 11:47:10.353523729 +0200
++++ usbirboy-0.2.1/usbirboykmod/usbirboy.c 2006-07-06 11:49:45.352506621 +0200
+@@ -65,6 +65,8 @@
+ #define __END_DEBUG }
+
+
++#define usbirboy_info(format, arg...) printk(KERN_INFO "%s: " format "\n" , \
++ DRIVER_NAME , ## arg)
+
+ /* Strait from lirc.h adopted ioctl definitions */
+ /* Lets hope they dont change those*/
+@@ -636,7 +638,7 @@
+
+
+ /* let the user know what node this device is now attached to */
+- info("USB-IR-Boy device attached to usbirboy with minor %d\n", irdev->minor);
++ usbirboy_info("USB-IR-Boy device attached to usbirboy with minor %d", irdev->minor);
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+ __END_DEBUG
+@@ -725,7 +727,7 @@
+ usbirboy_cleanup (usbirdev);
+ up (&disconnect_sem);
+
+- info( "USB-IR-Boy device disconnected. Minor: %d\n",minor);
++ usbirboy_info( "USB-IR-Boy device disconnected. Minor: %d",minor);
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+ __END_DEBUG
+@@ -754,7 +756,7 @@
+ return -1;
+ }
+
+- info( DRIVER_DESC ":" DRIVER_VERSION);
++ usbirboy_info( DRIVER_DESC ":" DRIVER_VERSION);
+
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+@@ -772,7 +774,7 @@
+ __END_DEBUG
+ usb_deregister (&usbirboy_driver);
+
+- info( "usbirboy_driver deregistered...\n");
++ usbirboy_info( "driver deregistered...");
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+ __END_DEBUG
diff --git a/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild b/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
index d98cf59f5a31..f655cc3b987c 100644
--- a/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
+++ b/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild,v 1.2 2006/07/03 08:39:09 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild,v 1.3 2006/07/06 09:54:30 zzam Exp $
inherit linux-mod eutils
@@ -39,6 +39,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-kernel-2.6.16.diff
epatch ${FILESDIR}/${P}-module_param.diff
+ epatch ${FILESDIR}/${P}-nice-kernel-msgs.diff
}
src_install() {