summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-10-27 09:55:27 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-10-27 09:55:27 +0000
commit7292583f3000df456da2cf64cb57e0207f79d83a (patch)
tree93febf2628c6b68b93bdd4c44d35608e7c04671f /app-misc/twin
parentset KDEDIRS=$KDEDIR:$PREFIX before running configure. this fixes the cases wh... (diff)
downloadgentoo-2-7292583f3000df456da2cf64cb57e0207f79d83a.tar.gz
gentoo-2-7292583f3000df456da2cf64cb57e0207f79d83a.tar.bz2
gentoo-2-7292583f3000df456da2cf64cb57e0207f79d83a.zip
version bump
Diffstat (limited to 'app-misc/twin')
-rw-r--r--app-misc/twin/ChangeLog9
-rw-r--r--app-misc/twin/files/digest-twin-0.4.51
-rw-r--r--app-misc/twin/twin-0.4.5.ebuild81
3 files changed, 90 insertions, 1 deletions
diff --git a/app-misc/twin/ChangeLog b/app-misc/twin/ChangeLog
index 4b7493e140a3..d3b55c153385 100644
--- a/app-misc/twin/ChangeLog
+++ b/app-misc/twin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/twin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/ChangeLog,v 1.4 2002/10/19 15:48:49 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/ChangeLog,v 1.5 2002/10/27 09:55:27 bcowan Exp $
+
+*twin-0.4.5 (27 Oct 2002)
+
+ 27 Oct 2002; Brad Cowan <bcowan@gentoo.org> twin-0.4.5.ebuild,
+ files/digest-twin-0.4.5 :
+
+ Version bump with many bugfixes.
*twin-0.4.4 (10 Sep 2002)
diff --git a/app-misc/twin/files/digest-twin-0.4.5 b/app-misc/twin/files/digest-twin-0.4.5
new file mode 100644
index 000000000000..a987ea238e1d
--- /dev/null
+++ b/app-misc/twin/files/digest-twin-0.4.5
@@ -0,0 +1 @@
+MD5 95f942a6f1be1144b11603579d6c366a twin-0.4.5.tar.gz 1075254
diff --git a/app-misc/twin/twin-0.4.5.ebuild b/app-misc/twin/twin-0.4.5.ebuild
new file mode 100644
index 000000000000..e5129cc93eb2
--- /dev/null
+++ b/app-misc/twin/twin-0.4.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.4.5.ebuild,v 1.1 2002/10/27 09:55:27 bcowan Exp $
+
+IUSE="X gtk ggi"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A text-mode window environment"
+SRC_URI="mirror://sourceforge/twin/${P}.tar.gz"
+HOMEPAGE="http://twin.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ ggi? ( >=media-libs/libggi-1.9 )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="--with-x --enable-hw-x11=yes"
+
+ use ggi \
+ && myconf="${myconf} --enable-hw-ggi=yes" \
+ || myconf="${myconf} --enable-hw-ggi=no"
+
+ use gtk \
+ && myconf="${myconf} --enable-tt-hw-gtk=yes" \
+ || myconf="${myconf} --enable-tt-hw-gtk=no"
+
+ econf \
+ --enable-shlibs=yes \
+ --enable-modules=yes \
+ --enable-unicode=yes \
+ --enable-socket=yes \
+ --enable-socket-gz=yes \
+ --enable-socket-pthreads=yes \
+ --enable-socket-alien=yes \
+ --enable-h2-tty-termcap=yes \
+ --enable-term=yes \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+
+ einstall || die
+
+ use X && ( \
+ insinto /usr/X11R6/lib/X11/fonts/misc
+ doins fonts/vga.pcf.gz
+ )
+
+ rm -rf ${D}/usr/share/twin/{BUGS,docs,COP*,READ*,Change*,INSTALL*}
+
+ dodoc BUGS COPYING* Change* README* TODO/TODO TODO/twin-thoughts
+ doman docs/twin.1; rm -rf docs/twin.1
+ dodoc docs/*
+
+}
+
+pkg_postinst() {
+ use X && ( \
+ /usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
+ /usr/X11R6/bin/xset fp rehash
+ )
+}
+
+pkg_postrm() {
+ use X && ( \
+ /usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
+ /usr/X11R6/bin/xset fp rehash
+ )
+}