summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Cunha <tcunha@gentoo.org>2009-11-05 15:38:58 +0000
committerTiago Cunha <tcunha@gentoo.org>2009-11-05 15:38:58 +0000
commit012af416b861cddb006a0c98c34bb1252b926551 (patch)
tree91f7396e8571182b01f50e0da27d8d280a67cf70 /app-misc/tmux
parentStable for HPPA (bug #291193). (diff)
downloadgentoo-2-012af416b861cddb006a0c98c34bb1252b926551.tar.gz
gentoo-2-012af416b861cddb006a0c98c34bb1252b926551.tar.bz2
gentoo-2-012af416b861cddb006a0c98c34bb1252b926551.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/ChangeLog7
-rw-r--r--app-misc/tmux/tmux-1.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 8ffac0823640..2ddf99543c1e 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.26 2009/10/30 22:57:26 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.27 2009/11/05 15:38:58 tcunha Exp $
+
+*tmux-1.1 (05 Nov 2009)
+
+ 05 Nov 2009; Tiago Cunha <tcunha@gentoo.org> +tmux-1.1.ebuild:
+ Version bump.
30 Oct 2009; Tiago Cunha <tcunha@gentoo.org> tmux-1.0.ebuild:
stable sparc, bug 290079
diff --git a/app-misc/tmux/tmux-1.1.ebuild b/app-misc/tmux/tmux-1.1.ebuild
new file mode 100644
index 000000000000..f4b0138e1953
--- /dev/null
+++ b/app-misc/tmux/tmux-1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.1.ebuild,v 1.1 2009/11/05 15:38:58 tcunha Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="vim-syntax? ( || (
+ app-editors/gvim
+ app-editors/vim ) )"
+
+src_compile() {
+ # The configure script isn't created by GNU autotools.
+ ./configure || die "configure failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin tmux || die "dobin failed"
+
+ dodoc CHANGES FAQ NOTES TODO || die "dodoc failed"
+ docinto examples
+ dodoc examples/*.conf || die "dodoc examples failed"
+
+ doman tmux.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim || die "doins syntax failed"
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
+ fi
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-1.1"
+ PREVIOUS_LESS_THAN_1_1=$?
+}
+
+pkg_postinst() {
+ if [[ ${PREVIOUS_LESS_THAN_1_1} -eq 0 ]]; then
+ ewarn "The 1.1 release replaced the internal locking mechanism by"
+ ewarn "executing an external command (you might want to install"
+ ewarn "app-misc/vlock and set the lock-command session option"
+ ewarn "accordingly), so the set-password command, and the -U command"
+ ewarn "line flag were removed, as well as -d, since tmux will now"
+ ewarn "automatically detect default colours."
+ fi
+}