summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-04 19:24:52 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-04 19:24:52 +0000
commit44abb9a99692b1ab35767e6215d7b69174146d58 (patch)
tree3ec9477eb5c9ee5849f478cd16e963cf1e534c9c /app-misc/tkpasman
parentcleanup (diff)
downloadgentoo-2-44abb9a99692b1ab35767e6215d7b69174146d58.tar.gz
gentoo-2-44abb9a99692b1ab35767e6215d7b69174146d58.tar.bz2
gentoo-2-44abb9a99692b1ab35767e6215d7b69174146d58.zip
Initial import.
Diffstat (limited to 'app-misc/tkpasman')
-rw-r--r--app-misc/tkpasman/ChangeLog9
-rw-r--r--app-misc/tkpasman/files/digest-tkpasman-2.21
-rw-r--r--app-misc/tkpasman/tkpasman-2.2.ebuild37
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/tkpasman/ChangeLog b/app-misc/tkpasman/ChangeLog
new file mode 100644
index 000000000000..bc08dcdef932
--- /dev/null
+++ b/app-misc/tkpasman/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-misc/tkpasman
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tkpasman/ChangeLog,v 1.1 2003/05/04 19:24:52 aliz Exp $
+
+*tkpasman-2.2 (04 May 2003)
+
+ 04 May 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Initial import. Ebuild submitted by Wilbert Berendsen <wilbert@oswf.org>
+ in #13710.
diff --git a/app-misc/tkpasman/files/digest-tkpasman-2.2 b/app-misc/tkpasman/files/digest-tkpasman-2.2
new file mode 100644
index 000000000000..c6280576303f
--- /dev/null
+++ b/app-misc/tkpasman/files/digest-tkpasman-2.2
@@ -0,0 +1 @@
+MD5 acd30c3f0e56fae8289ee2386ad1864d TkPasMan-2.2.tar.gz 30944
diff --git a/app-misc/tkpasman/tkpasman-2.2.ebuild b/app-misc/tkpasman/tkpasman-2.2.ebuild
new file mode 100644
index 000000000000..7ee901ea5c46
--- /dev/null
+++ b/app-misc/tkpasman/tkpasman-2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tkpasman/tkpasman-2.2.ebuild,v 1.1 2003/05/04 19:24:52 aliz Exp $
+
+MY_P="TkPasMan-${PV}"
+
+SRC_URI="http://www.xs4all.nl/~wbsoft/linux/projects/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+S=${WORKDIR}/${MY_P}
+
+IUSE="ssl"
+
+DEPEND=">=dev-lang/tcl-8.3"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ virtual/x11
+ >=dev-lang/tk-8.3
+ >=dev-lang/tcl-8.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ cp config config.old
+ use ssl || sed "s:^USE_OPENSSL=true:USE_OPENSSL=false:g" config.old >config
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dobin tkpasman
+ dodoc README ChangeLog TODO WARNING INSTALL COPYING
+}
+