summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-26 17:22:44 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-26 17:22:44 +0000
commit2518bd3973c27eb2a35bb886c76ebe7e3ee55f20 (patch)
tree3da17e7033961aeb5d5116045a07bfc8d557f9dd /app-misc/specto
parentUpdated zipcode. Clean up ebuild. (diff)
downloadgentoo-2-2518bd3973c27eb2a35bb886c76ebe7e3ee55f20.tar.gz
gentoo-2-2518bd3973c27eb2a35bb886c76ebe7e3ee55f20.tar.bz2
gentoo-2-2518bd3973c27eb2a35bb886c76ebe7e3ee55f20.zip
Initial import
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/specto')
-rw-r--r--app-misc/specto/ChangeLog11
-rw-r--r--app-misc/specto/files/specto-0.3.1-icon-theme.patch30
-rw-r--r--app-misc/specto/metadata.xml10
-rw-r--r--app-misc/specto/specto-0.3.1.ebuild35
4 files changed, 86 insertions, 0 deletions
diff --git a/app-misc/specto/ChangeLog b/app-misc/specto/ChangeLog
new file mode 100644
index 000000000000..704f60a615de
--- /dev/null
+++ b/app-misc/specto/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-misc/specto
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/specto/ChangeLog,v 1.1 2010/10/26 17:22:44 xmw Exp $
+
+*specto-0.3.1 (26 Oct 2010)
+
+ 26 Oct 2010; Michael Weber <xmw@gentoo.org> +specto-0.3.1.ebuild,
+ +files/specto-0.3.1-icon-theme.patch, +metadata.xml:
+ Initial import fixes bug #174604 (thanks to unnamedrambler@gmail.com).
+ Thanks to Jakub and Thomas in sunrise.
+
diff --git a/app-misc/specto/files/specto-0.3.1-icon-theme.patch b/app-misc/specto/files/specto-0.3.1-icon-theme.patch
new file mode 100644
index 000000000000..fcb7d1f0f241
--- /dev/null
+++ b/app-misc/specto/files/specto-0.3.1-icon-theme.patch
@@ -0,0 +1,30 @@
+Replace some GNOME icons with their FreeDesktop equivalents
+so that it works with oxygen as a theme.
+
+--- specto-0.3.1/spectlib/notifier.py
++++ specto-0.3.1/spectlib/notifier.py
+@@ -194,11 +194,11 @@
+ """ show the right icon for the status from the watch. """
+ watch = self.specto.watch_db[id]
+ statusbar = self.wTree.get_widget("statusbar1")
+- icon = self.get_icon("error", 50, False)
++ icon = self.get_icon("dialog-error", 50, False)
+
+ try:
+ if status == "checking":
+- icon = self.get_icon("reload", 0, False)
++ icon = self.get_icon("view-refresh", 0, False)
+ statusbar.push(0, (datetime.today().strftime("%H:%M") + " - " + _('The watch "%s" is checking.') % watch.name))
+
+ elif status == "idle":
+@@ -220,8 +220,8 @@
+
+ elif status == "error":
+ statusbar.push(0, (datetime.today().strftime("%H:%M") + " - " + _('The watch "%s" has a problem.') % watch.name))
+- balloon_icon = self.get_icon("error", 0, True)
+- icon = self.get_icon("error", 50, False)
++ balloon_icon = self.get_icon("dialog-error", 0, True)
++ icon = self.get_icon("dialog-error", 50, False)
+ if self.specto.specto_gconf.get_entry("pop_toast") == True:
+ self.balloon.show_toast(watch.error_message, balloon_icon, urgency="critical", summary=(_("%s encountered a problem") % watch.name))
+ if self.specto.specto_gconf.get_entry("use_problem_sound"):
diff --git a/app-misc/specto/metadata.xml b/app-misc/specto/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/app-misc/specto/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/app-misc/specto/specto-0.3.1.ebuild b/app-misc/specto/specto-0.3.1.ebuild
new file mode 100644
index 000000000000..fe8b49f4cdf3
--- /dev/null
+++ b/app-misc/specto/specto-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/specto/specto-0.3.1.ebuild,v 1.1 2010/10/26 17:22:44 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+PYTHON_MODNAME="spectlib"
+
+inherit distutils eutils
+
+DESCRIPTION="watch configurable events and trigger notifications"
+HOMEPAGE="http://specto.sourceforge.net/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_it
+ linguas_pt_BR linguas_ro linguas_sv linguas_tr"
+
+RDEPEND="dev-python/gconf-python
+ dev-python/dbus-python
+ dev-python/notify-python
+ >=dev-python/pygtk-2.10"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-icon-theme.patch
+
+ sed -e "s:share/doc/specto:share/doc/${PF}:" \
+ -i setup.py spectlib/util.py || die
+
+ sed -e "/^i18n_languages = /s: = .*: = \"${LINGUAS}\":" \
+ -i setup.py || die
+}