summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenneth Prugh <ken69267@gentoo.org>2009-06-10 01:07:49 +0000
committerKenneth Prugh <ken69267@gentoo.org>2009-06-10 01:07:49 +0000
commitbb15f7c2ca747c96ea82c6631117e34de78b7962 (patch)
tree7f37f2f815bc8c05e13dd7259bce20abe45d128b /app-misc/slashtime
parentold (diff)
downloadgentoo-2-bb15f7c2ca747c96ea82c6631117e34de78b7962.tar.gz
gentoo-2-bb15f7c2ca747c96ea82c6631117e34de78b7962.tar.bz2
gentoo-2-bb15f7c2ca747c96ea82c6631117e34de78b7962.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/slashtime')
-rw-r--r--app-misc/slashtime/ChangeLog9
-rw-r--r--app-misc/slashtime/slashtime-0.5.10.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/app-misc/slashtime/ChangeLog b/app-misc/slashtime/ChangeLog
index 5b485a29b40b..20a97138387a 100644
--- a/app-misc/slashtime/ChangeLog
+++ b/app-misc/slashtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/slashtime
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.9 2008/11/26 19:11:46 serkan Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.10 2009/06/10 01:07:49 ken69267 Exp $
+
+*slashtime-0.5.10 (10 Jun 2009)
+
+ 10 Jun 2009; Kenneth Prugh <ken69267@gentoo.org> +slashtime-0.5.10.ebuild:
+ version bump
26 Nov 2008; Serkan Kaba <serkan@gentoo.org>
-files/slashtime-0.5.9-jardir-and-symlink.patch, -slashtime-0.5.9.ebuild:
diff --git a/app-misc/slashtime/slashtime-0.5.10.ebuild b/app-misc/slashtime/slashtime-0.5.10.ebuild
new file mode 100644
index 000000000000..a3b09ab6226d
--- /dev/null
+++ b/app-misc/slashtime/slashtime-0.5.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/slashtime-0.5.10.ebuild,v 1.1 2009/06/10 01:07:49 ken69267 Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2
+
+DESCRIPTION="View the time at locations around the world"
+HOMEPAGE="http://research.operationaldynamics.com/projects/slashtime/"
+SRC_URI="http://research.operationaldynamics.com/projects/${PN}/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP=">=dev-java/java-gnome-4.0.9:4.0"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+src_configure() {
+ # Handwritten in perl so not using econf
+ ./configure prefix=/usr jardir=/usr/share/${PN}/lib || die
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ #this is needed to generate the slashtime jar
+ emake -j1 DESTDIR="${D}" install || die "emake install failed."
+
+ java-pkg_register-dependency java-gnome-4.0 gtk.jar
+ java-pkg_regjar /usr/share/${PN}/lib/${PN}.jar
+
+ #Replace slashtime launcher with our own.
+ rm "${D}"/usr/bin/slashtime || die
+ java-pkg_dolauncher ${PN} --main slashtime.client.Master \
+ --pwd /usr
+
+ dodoc AUTHORS HACKING PLACES README TODO || die "dodoc failed."
+
+ use source && java-pkg_dosrc src/java/slashtime
+}