summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenneth Prugh <ken69267@gentoo.org>2008-08-18 02:16:05 +0000
committerKenneth Prugh <ken69267@gentoo.org>2008-08-18 02:16:05 +0000
commit9f1f941b82e72b83f7192db716e3a453c3d650a0 (patch)
treedd952e513bdd835fbec1e7a43d5601ff144b1520 /app-misc/slashtime
parentversion bump (diff)
downloadgentoo-2-9f1f941b82e72b83f7192db716e3a453c3d650a0.tar.gz
gentoo-2-9f1f941b82e72b83f7192db716e3a453c3d650a0.tar.bz2
gentoo-2-9f1f941b82e72b83f7192db716e3a453c3d650a0.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'app-misc/slashtime')
-rw-r--r--app-misc/slashtime/ChangeLog7
-rw-r--r--app-misc/slashtime/slashtime-0.5.6.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-misc/slashtime/ChangeLog b/app-misc/slashtime/ChangeLog
index 64a402447b17..f551118bf66f 100644
--- a/app-misc/slashtime/ChangeLog
+++ b/app-misc/slashtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/slashtime
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.3 2008/07/27 17:52:22 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.4 2008/08/18 02:16:05 ken69267 Exp $
+
+*slashtime-0.5.6 (18 Aug 2008)
+
+ 18 Aug 2008; Kenneth Prugh <ken69267@gentoo.org> +slashtime-0.5.6.ebuild:
+ version bump
27 Jul 2008; Kenneth Prugh <ken69267@gentoo.org> slashtime-0.5.4.ebuild,
slashtime-0.5.5.ebuild:
diff --git a/app-misc/slashtime/slashtime-0.5.6.ebuild b/app-misc/slashtime/slashtime-0.5.6.ebuild
new file mode 100644
index 000000000000..7d87d7605bc7
--- /dev/null
+++ b/app-misc/slashtime/slashtime-0.5.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/slashtime-0.5.6.ebuild,v 1.1 2008/08/18 02:16:05 ken69267 Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2
+
+DESCRIPTION="View the time at locations around the world"
+HOMEPAGE="http://research.operationaldynamics.com/projects/slashtime/"
+SRC_URI="http://research.operationaldynamics.com/projects/${PN}/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP=">=dev-java/java-gnome-4.0.8:4.0"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+src_compile() {
+ # Handwritten in perl so not using econf
+ ./configure --prefix=/usr || die
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ #this is needed to generate the slashtime jar
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ #remove incorrect install path
+ rm -r "${D}"/usr/share/java/
+ rm "${D}"/usr/bin/slashtime
+
+ java-pkg_register-dependency java-gnome-4.0 gtk-4.0.jar
+ java-pkg_dojar tmp/${PN}.jar
+ java-pkg_dolauncher ${PN} --main slashtime.client.Master \
+ --pwd /usr
+
+ dodoc AUTHORS HACKING PLACES README TODO || die "dodoc failed."
+
+ use source && java-pkg_dosrc src/java/slashtime
+}