summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenneth Prugh <ken69267@gentoo.org>2008-11-26 04:28:52 +0000
committerKenneth Prugh <ken69267@gentoo.org>2008-11-26 04:28:52 +0000
commit943593cd20f2b8ef305e02ac8f9e3bbd47b63978 (patch)
tree0336919217bf0d1d5d05f92c9304a3840bd3fad6 /app-misc/slashtime
parentFix building with --as-needed, respect LDFLAGS, don't strip. (diff)
downloadgentoo-2-943593cd20f2b8ef305e02ac8f9e3bbd47b63978.tar.gz
gentoo-2-943593cd20f2b8ef305e02ac8f9e3bbd47b63978.tar.bz2
gentoo-2-943593cd20f2b8ef305e02ac8f9e3bbd47b63978.zip
version bump
(Portage version: 2.1.6_rc1/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-misc/slashtime')
-rw-r--r--app-misc/slashtime/ChangeLog7
-rw-r--r--app-misc/slashtime/slashtime-0.5.9a.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-misc/slashtime/ChangeLog b/app-misc/slashtime/ChangeLog
index fe1c44250682..bf03be7075d9 100644
--- a/app-misc/slashtime/ChangeLog
+++ b/app-misc/slashtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/slashtime
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.7 2008/11/25 18:51:47 serkan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.8 2008/11/26 04:28:52 ken69267 Exp $
+
+*slashtime-0.5.9a (26 Nov 2008)
+
+ 26 Nov 2008; Kenneth Prugh <ken69267@gentoo.org> +slashtime-0.5.9a.ebuild:
+ version bump
*slashtime-0.5.9 (25 Nov 2008)
diff --git a/app-misc/slashtime/slashtime-0.5.9a.ebuild b/app-misc/slashtime/slashtime-0.5.9a.ebuild
new file mode 100644
index 000000000000..f88fbdec068c
--- /dev/null
+++ b/app-misc/slashtime/slashtime-0.5.9a.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/slashtime-0.5.9a.ebuild,v 1.1 2008/11/26 04:28:52 ken69267 Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2
+
+DESCRIPTION="View the time at locations around the world"
+HOMEPAGE="http://research.operationaldynamics.com/projects/slashtime/"
+SRC_URI="http://research.operationaldynamics.com/projects/${PN}/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP=">=dev-java/java-gnome-4.0.9:4.0"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+src_configure() {
+ # Handwritten in perl so not using econf
+ ./configure prefix=/usr jardir=/usr/share/${PN}/lib || die
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ #this is needed to generate the slashtime jar
+ emake -j1 DESTDIR="${D}" install || die "emake install failed."
+
+ java-pkg_register-dependency java-gnome-4.0 gtk.jar
+ java-pkg_regjar /usr/share/${PN}/lib/${PN}.jar
+
+ #Replace slashtime launcher with our own.
+ rm "${D}"/usr/bin/slashtime || die
+ java-pkg_dolauncher ${PN} --main slashtime.client.Master \
+ --pwd /usr
+
+ dodoc AUTHORS HACKING PLACES README TODO || die "dodoc failed."
+
+ use source && java-pkg_dosrc src/java/slashtime
+}