summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-27 16:34:30 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-27 16:34:30 +0000
commit4cccd32f5efd7a631126ac913591b610c69fe9e4 (patch)
tree1297db554359fe29fe1c2964ca624dc5fe8ad2d1 /app-misc/pystopwatch
parentConvert to distutils-r1. (diff)
downloadgentoo-2-4cccd32f5efd7a631126ac913591b610c69fe9e4.tar.gz
gentoo-2-4cccd32f5efd7a631126ac913591b610c69fe9e4.tar.bz2
gentoo-2-4cccd32f5efd7a631126ac913591b610c69fe9e4.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-misc/pystopwatch')
-rw-r--r--app-misc/pystopwatch/ChangeLog10
-rw-r--r--app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/app-misc/pystopwatch/ChangeLog b/app-misc/pystopwatch/ChangeLog
index 7c83c4577c03..579af7b4502e 100644
--- a/app-misc/pystopwatch/ChangeLog
+++ b/app-misc/pystopwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/pystopwatch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pystopwatch/ChangeLog,v 1.6 2013/07/07 09:32:30 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pystopwatch/ChangeLog,v 1.7 2014/12/27 16:34:30 mgorny Exp $
+
+*pystopwatch-2012.12.24.1-r1 (27 Dec 2014)
+
+ 27 Dec 2014; Michał Górny <mgorny@gentoo.org>
+ +pystopwatch-2012.12.24.1-r1.ebuild:
+ Convert to python-single-r1.
07 Jul 2013; Agostino Sarubbo <ago@gentoo.org>
pystopwatch-2012.12.24.1.ebuild:
diff --git a/app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild b/app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild
new file mode 100644
index 000000000000..bfce99a96fd0
--- /dev/null
+++ b/app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild,v 1.1 2014/12/27 16:34:30 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="clock and two countdown functions that can minimize to the tray"
+HOMEPAGE="http://xyne.archlinux.ca/projects/pystopwatch"
+SRC_URI="http://xyne.archlinux.ca/projects/${PN}/src/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_prepare() {
+ unpack ./man/${PN}.1.gz
+}
+
+src_install() {
+ python_doscript ${PN}
+ doman ${PN}.1
+}