summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-07-12 16:03:31 +0000
committerBen Lutgens <lamer@gentoo.org>2001-07-12 16:03:31 +0000
commit8fa9f65b3e3bef5c19c777dc97461869d2cb1720 (patch)
tree25aa48d519c88ebed3bb24e1adb4c9acf4541d51 /app-misc/jpilot
parentremoved pilot-link from mask. (diff)
downloadgentoo-2-8fa9f65b3e3bef5c19c777dc97461869d2cb1720.tar.gz
gentoo-2-8fa9f65b3e3bef5c19c777dc97461869d2cb1720.tar.bz2
gentoo-2-8fa9f65b3e3bef5c19c777dc97461869d2cb1720.zip
added a new version of jpilot ebuild that includes the malsync plugin for
jpilot. Make sure you read all the docs in /usr/share/doc/jpilot-0.99 if you intend to use this plugin. You'll also need an AvantGo account as well as the appropriate .prc files installed into your palm. Well worth it though to be able to sync mapquest directions with your palm as well as new etc.
Diffstat (limited to 'app-misc/jpilot')
-rw-r--r--app-misc/jpilot/files/digest-jpilot-0.99-r13
-rw-r--r--app-misc/jpilot/jpilot-0.99-r1.ebuild64
2 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/jpilot/files/digest-jpilot-0.99-r1 b/app-misc/jpilot/files/digest-jpilot-0.99-r1
new file mode 100644
index 000000000000..47c3d21eae92
--- /dev/null
+++ b/app-misc/jpilot/files/digest-jpilot-0.99-r1
@@ -0,0 +1,3 @@
+MD5 a6c8c1a9bc74f8a3f8403c451fdaef0f jpilot-0.99.tar.gz
+MD5 61f5c38dad01977a1e3d70e4cdee7e7d jpilot-syncmal_0.62.tar.gz
+MD5 b2a64720dc4c6e33d2b247c2d53700e4 malsync_2.0.6.src.tar.gz
diff --git a/app-misc/jpilot/jpilot-0.99-r1.ebuild b/app-misc/jpilot/jpilot-0.99-r1.ebuild
new file mode 100644
index 000000000000..15f619721449
--- /dev/null
+++ b/app-misc/jpilot/jpilot-0.99-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+A="${P}.tar.gz jpilot-syncmal_0.62.tar.gz malsync_2.0.6.src.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+SRC_URI="http://jpilot.org/${P}.tar.gz
+http://www.tomw.org/malsync/malsync_2.0.6.src.tar.gz
+http://people.atl.mediaone.net/jasonday/code/syncmal/jpilot-syncmal_0.62.tar.gz"
+HOMEPAGE="http://jpilot.org/"
+# In order to use the malsync plugin you'll need to refer to the homepage
+# for jpilot-syncmal http://people.atl.mediaone.net/jasonday/code/syncmal/
+# And you'll also need an avangto account.
+
+DEPEND=">=x11-libs/gtk+-1.2.0 >=dev-libs/pilot-link-0.9.5"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ unpack jpilot-syncmal_0.62.tar.gz
+ cd ${S}/jpilot-syncmal_0.62
+ unpack malsync_2.0.6.src.tar.gz
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ NLS_OPTION="--disable-nls"
+ fi
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST} ${NLS_OPTION}
+
+ # cheap fix?
+ patch -p0 < ${FILESDIR}/${P}.patch
+
+ # make sure we use $CFLAGS
+ mv Makefile Makefile.old
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.old > Makefile
+
+ try make
+
+ cd ${S}/jpilot-syncmal_0.62
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ make
+}
+
+src_install() {
+
+ make prefix=${D}/usr/X11R6 install
+ insinto /usr/X11R6/share/jpilot/plugins
+ doins jpilot-syncmal_0.62/.libs/libsyncmal.so
+ dodoc README TODO UPGRADING ABOUT-NLS BUGS\
+ CHANGELOG COPYING CREDITS INSTALL
+ doman docs/*.1
+ newdoc jpilot-syncmal_0.62/ChangeLog ChangeLog.jpilot-syncmal
+ newdoc jpilot-syncmal_0.62/README.1st README.1st.jpilot-syncmal
+ newdoc jpilot-syncmal_0.62/README README.jpilot-syncmal
+ dodoc pilot-syncmal_0.62/malsync/doc/README_AvantGo
+ dodoc pilot-syncmal_0.62/malsync/doc/README_malsync
+
+
+}
+