summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-05-02 12:24:25 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-05-02 12:24:25 +0000
commit717ffe1ff9d8ec123823b73fab6d57b37054f59d (patch)
tree551bf40601f11c2e642f9211e8a9da1b7b0a54ae /app-misc/hivex/files
parentVersion bump redis to 2.4.13 (bug 413357). (diff)
downloadgentoo-2-717ffe1ff9d8ec123823b73fab6d57b37054f59d.tar.gz
gentoo-2-717ffe1ff9d8ec123823b73fab6d57b37054f59d.tar.bz2
gentoo-2-717ffe1ff9d8ec123823b73fab6d57b37054f59d.zip
Fix runpath and ldflags in ruby bindings, bug 412099
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/hivex/files')
-rw-r--r--app-misc/hivex/files/1.3.3/0004-ruby_runpath_fix-1.3.3.patch11
-rw-r--r--app-misc/hivex/files/1.3.5/0004-ruby_runpath_fix-1.3.5.patch11
-rw-r--r--app-misc/hivex/files/autoconf_fix-1.3.1.patch104
-rw-r--r--app-misc/hivex/files/ruby_runpath_fix-1.3.2.patch11
4 files changed, 33 insertions, 104 deletions
diff --git a/app-misc/hivex/files/1.3.3/0004-ruby_runpath_fix-1.3.3.patch b/app-misc/hivex/files/1.3.3/0004-ruby_runpath_fix-1.3.3.patch
new file mode 100644
index 000000000000..5b77ede9d5c2
--- /dev/null
+++ b/app-misc/hivex/files/1.3.3/0004-ruby_runpath_fix-1.3.3.patch
@@ -0,0 +1,11 @@
+--- ruby/Rakefile.in.orig 2012-04-16 20:16:14.989449899 +0200
++++ ruby/Rakefile.in 2012-04-16 20:17:08.006443779 +0200
+@@ -38,7 +38,7 @@
+ # Build locally
+
+ file MAKEFILE => EXT_CONF do |t|
+- unless sh "top_srcdir=$(pwd)/@top_srcdir@; top_builddir=$(pwd)/@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; cd #{File::dirname(EXT_CONF)}; ruby #{File::basename(EXT_CONF)} --with-_hivex-include=$top_srcdir/lib --with-_hivex-lib=$top_builddir/lib/.libs"
++ unless sh "top_srcdir=@top_srcdir@; top_builddir=@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; mkdir -p @builddir@/ext/hivex; cd #{File::dirname(EXT_CONF)}; ruby #{File::basename(EXT_CONF)} --with-_hivex-include=../../$top_srcdir/lib --with-_hivex-lib=../../$top_builddir/lib/.libs --with-ldflags=\"$LDFLAGS\""
+ $stderr.puts "Failed to run extconf"
+ break
+ end
diff --git a/app-misc/hivex/files/1.3.5/0004-ruby_runpath_fix-1.3.5.patch b/app-misc/hivex/files/1.3.5/0004-ruby_runpath_fix-1.3.5.patch
new file mode 100644
index 000000000000..25624c7104d1
--- /dev/null
+++ b/app-misc/hivex/files/1.3.5/0004-ruby_runpath_fix-1.3.5.patch
@@ -0,0 +1,11 @@
+--- ruby/Rakefile.in 2012-03-13 19:46:43.000000000 +0400
++++ ruby/Rakefile.in 2012-04-15 19:02:42.337118192 +0400
+@@ -38,7 +38,7 @@
+ # Build locally
+
+ file MAKEFILE => EXT_CONF do |t|
+- unless sh "top_srcdir=$(pwd)/@top_srcdir@; top_builddir=$(pwd)/@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; mkdir -p @builddir@/ext/hivex; cd @builddir@/ext/hivex; @RUBY@ #{EXT_CONF} --with-_hivex-include=$top_srcdir/lib --with-_hivex-lib=$top_builddir/lib/.libs"
++ unless sh "top_srcdir=@top_srcdir@; top_builddir=@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; mkdir -p @builddir@/ext/hivex; cd @builddir@/ext/hivex; @RUBY@ #{EXT_CONF} --with-_hivex-include=../../$top_srcdir/lib --with-_hivex-lib=../../$top_builddir/lib/.libs --with-ldflags=\"$LDFLAGS\""
+ $stderr.puts "Failed to run extconf"
+ break
+ end
diff --git a/app-misc/hivex/files/autoconf_fix-1.3.1.patch b/app-misc/hivex/files/autoconf_fix-1.3.1.patch
deleted file mode 100644
index 2a9495b51cea..000000000000
--- a/app-misc/hivex/files/autoconf_fix-1.3.1.patch
+++ /dev/null
@@ -1,104 +0,0 @@
---- configure.ac.orig 2011-08-15 22:29:28.309745342 +0300
-+++ configure.ac 2011-08-15 22:34:54.324549151 +0300
-@@ -170,11 +170,18 @@
- AC_SUBST([LIBXML2_CFLAGS])
- AC_SUBST([LIBXML2_LIBS])
-
-+
-+dnl ////////////////////////////////////////////////////////////////////////////
- dnl Check for OCaml (optional, for OCaml bindings).
-+
-+AC_ARG_ENABLE([ocaml],
-+ AS_HELP_STRING([--with-ocaml],[build Ocaml binding]))
-+
-+
- AC_PROG_OCAML
- AC_PROG_FINDLIB
- AM_CONDITIONAL([HAVE_OCAML],
-- [test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"])
-+ [test "x$OCAMLC" != "xno" -a "x$OCAMLFIND" != "xno" -a "x$enable_ocaml" = "xyes"])
- AM_CONDITIONAL([HAVE_OCAMLOPT],
- [test "x$OCAMLOPT" != "xno" && test "x$OCAMLFIND" != "xno"])
-
-@@ -207,6 +214,8 @@
- rm -f conftest conftest.* conftest_ml.*
- fi
-
-+dnl ///////////////////////////////////////////////////////////////////////////////////////
-+
- dnl Check for Perl (optional, for Perl bindings).
- dnl XXX This isn't quite right, we should check for Perl devel library.
- AC_CHECK_PROG([PERL],[perl],[perl],[no])
-@@ -214,21 +223,35 @@
- dnl Check for Perl modules that must be present to compile and
- dnl test the Perl bindings.
- missing_perl_modules=no
--for pm in Test::More ExtUtils::MakeMaker IO::Stringy; do
-- AC_MSG_CHECKING([for $pm])
-- if ! perl -M$pm -e1 >/dev/null 2>&1; then
-- AC_MSG_RESULT([no])
-- missing_perl_modules=yes
-- else
-- AC_MSG_RESULT([yes])
-- fi
--done
--if test "x$missing_perl_modules" = "xyes"; then
-- AC_MSG_WARN([some Perl modules required to compile or test the Perl bindings are missing])
--fi
-+
-+AC_ARG_ENABLE([perl],
-+ AS_HELP_STRING([--with-perl],[build Perl binding]))
-+
-+
-+PERL=
-+AS_IF([test "x$enable_perl" != "xno" ],[
-+ AC_CHECK_PROG([PERL],[perl],[yes],[no])
-+
-+ for pm in Test::More ExtUtils::MakeMaker IO::Stringy; do
-+ AC_MSG_CHECKING([for $pm])
-+ if ! perl -M$pm -e1 >/dev/null 2>&1; then
-+ AC_MSG_RESULT([no])
-+ missing_perl_modules=yes
-+ else
-+ AC_MSG_RESULT([yes])
-+ fi
-+ done
-+
-+ AS_IF([test "x$missing_perl_modules" = "xyes"],
-+ [AC_MSG_FAILURE([some Perl modules required to compile or test the Perl bindings are missing])],
-+ )
-+])
-+
-
- AM_CONDITIONAL([HAVE_PERL],
-- [test "x$PERL" != "xno" && test "x$missing_perl_modules" != "xyes"])
-+ [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes" -a "x$enable_perl" = "xyes"])
-+
-+dnl //////////////////////////////////////////////////////////////////////////////////////////////////
-
- dnl Check for Python (optional, for Python bindings).
- AC_CHECK_PROG([PYTHON],[python],[python],[no])
-@@ -266,15 +289,21 @@
- AC_SUBST(PYTHON_INCLUDEDIR)
- AC_SUBST(PYTHON_SITE_PACKAGES)
-
-+AC_ARG_ENABLE([python],
-+ AS_HELP_STRING([--with-python],[build Python binding]))
-+
- AM_CONDITIONAL([HAVE_PYTHON],
-- [test "x$PYTHON_INCLUDEDIR" != "x" && test "x$PYTHON_SITE_PACKAGES" != "x"])
-+ [test "x$PYTHON_INCLUDEDIR" != "x" -a "x$PYTHON_SITE_PACKAGES" != "x" -a "x$enable_python" = "xyes"])
-
- dnl Check for Ruby and rake (optional, for Ruby bindings).
- AC_CHECK_LIB([ruby],[ruby_init],[HAVE_LIBRUBY=1],[HAVE_LIBRUBY=0])
- AC_CHECK_PROG([RAKE],[rake],[rake],[no])
-
-+AC_ARG_ENABLE([ruby],
-+ AS_HELP_STRING([--with-ruby],[build Ruby binding]))
-+
- AM_CONDITIONAL([HAVE_RUBY],
-- [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY"])
-+ [test "x$RAKE" != "xno" && test -n "$HAVE_LIBRUBY" -a "x$enable_ruby" = "xyes"])
-
- dnl dnl Check for Java.
- dnl AC_ARG_WITH(java_home,
diff --git a/app-misc/hivex/files/ruby_runpath_fix-1.3.2.patch b/app-misc/hivex/files/ruby_runpath_fix-1.3.2.patch
new file mode 100644
index 000000000000..5b77ede9d5c2
--- /dev/null
+++ b/app-misc/hivex/files/ruby_runpath_fix-1.3.2.patch
@@ -0,0 +1,11 @@
+--- ruby/Rakefile.in.orig 2012-04-16 20:16:14.989449899 +0200
++++ ruby/Rakefile.in 2012-04-16 20:17:08.006443779 +0200
+@@ -38,7 +38,7 @@
+ # Build locally
+
+ file MAKEFILE => EXT_CONF do |t|
+- unless sh "top_srcdir=$(pwd)/@top_srcdir@; top_builddir=$(pwd)/@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; cd #{File::dirname(EXT_CONF)}; ruby #{File::basename(EXT_CONF)} --with-_hivex-include=$top_srcdir/lib --with-_hivex-lib=$top_builddir/lib/.libs"
++ unless sh "top_srcdir=@top_srcdir@; top_builddir=@top_builddir@; export ARCHFLAGS=\"-arch $(uname -m)\"; mkdir -p @builddir@/ext/hivex; cd #{File::dirname(EXT_CONF)}; ruby #{File::basename(EXT_CONF)} --with-_hivex-include=../../$top_srcdir/lib --with-_hivex-lib=../../$top_builddir/lib/.libs --with-ldflags=\"$LDFLAGS\""
+ $stderr.puts "Failed to run extconf"
+ break
+ end