summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-06-09 07:44:44 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-06-09 07:44:44 +0000
commit97fff8455160f9696dbb5d4041356854aec717f8 (patch)
tree55b17d18d32581a4c9053191c8b11067897e0620 /app-misc/gramps
parentstable x86, bug 273297 (diff)
downloadgentoo-2-97fff8455160f9696dbb5d4041356854aec717f8.tar.gz
gentoo-2-97fff8455160f9696dbb5d4041356854aec717f8.tar.bz2
gentoo-2-97fff8455160f9696dbb5d4041356854aec717f8.zip
version bump: translation updates and bug fixes
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/ChangeLog9
-rw-r--r--app-misc/gramps/gramps-3.1.2.ebuild85
2 files changed, 92 insertions, 2 deletions
diff --git a/app-misc/gramps/ChangeLog b/app-misc/gramps/ChangeLog
index 516b523721d1..714ed3ad88a8 100644
--- a/app-misc/gramps/ChangeLog
+++ b/app-misc/gramps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gramps
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.108 2009/06/03 12:48:58 fauli Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.109 2009/06/09 07:44:44 fauli Exp $
+
+*gramps-3.1.2 (09 Jun 2009)
+
+ 09 Jun 2009; Christian Faulhammer <fauli@gentoo.org> +gramps-3.1.2.ebuild:
+ version bump: translation updates and bug fixes
03 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
-files/gramps-3.0.3_fix-installation-race-condition.patch,
diff --git a/app-misc/gramps/gramps-3.1.2.ebuild b/app-misc/gramps/gramps-3.1.2.ebuild
new file mode 100644
index 000000000000..d353f178ac03
--- /dev/null
+++ b/app-misc/gramps/gramps-3.1.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-3.1.2.ebuild,v 1.1 2009/06/09 07:44:44 fauli Exp $
+
+EAPI=2
+
+inherit autotools eutils gnome2 python
+
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+HOMEPAGE="http://www.gramps-project.org/"
+SRC_URI="mirror://sourceforge/gramps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="gnome mozembed reports spell webkit"
+
+RDEPEND=">=dev-lang/python-2.5[berkdb]
+ >=dev-python/pygtk-2.10.0
+ x11-misc/xdg-utils
+ gnome-base/librsvg:2
+ gnome? ( dev-python/libgnome-python
+ dev-python/gconf-python )
+ mozembed? ( dev-python/gtkmozembed-python )
+ spell? ( dev-python/gtkspell-python
+ dev-python/pyenchant )
+ reports? ( media-gfx/graphviz )
+ webkit? ( dev-python/pywebkitgtk )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/libiconv
+ dev-util/pkgconfig"
+
+DOCS="NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-mime-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ eautoreconf
+ # This is for bug 215944, so .pyo/.pyc files don't get into the
+ # file system
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ python_version
+
+ # Fix install path.
+ einfo "Fix installation path"
+ find . -iname 'Makefile.in' | xargs \
+ sed "s;\(pkgdatadir = \)\(\$(datadir)\);\1$(python_get_sitedir);" -i \
+ || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/Makefile.in || die
+
+ sed "s;\$(prefix)/share/gramps;/$(python_get_sitedir)/@PACKAGE@;" \
+ -i src/docgen/Makefile.in || die
+
+ einfo "Fix wrapper script"
+ sed "s;@datadir@;$(python_get_sitedir);" \
+ -i gramps.sh.in || die
+
+ einfo "Fix icon location"
+ sed "s;gramps/;pixmap/;g" -i data/gramps.keys.in || die
+}
+
+src_install() {
+ python_need_rebuild
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_version
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}