summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2007-10-04 08:43:58 +0000
committerRobert Buchholz <rbu@gentoo.org>2007-10-04 08:43:58 +0000
commit8f76a5b10975c7ca515b703bd2413e19730cc432 (patch)
tree4deca13ce345f160d7d697fb5d883e98de07a351 /app-misc/g15daemon
parentfixing digest for x86 (diff)
downloadgentoo-2-8f76a5b10975c7ca515b703bd2413e19730cc432.tar.gz
gentoo-2-8f76a5b10975c7ca515b703bd2413e19730cc432.tar.bz2
gentoo-2-8f76a5b10975c7ca515b703bd2413e19730cc432.zip
New POSIX init script by Peter Alfredsen and Roy Marples (bug #194365)
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-misc/g15daemon')
-rw-r--r--app-misc/g15daemon/ChangeLog10
-rw-r--r--app-misc/g15daemon/files/digest-g15daemon-1.2.7-r13
-rw-r--r--app-misc/g15daemon/files/digest-g15daemon-1.9.0-r1 (renamed from app-misc/g15daemon/files/digest-g15daemon-1.9.0)0
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.2.7-r1.initd40
-rw-r--r--app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild131
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild (renamed from app-misc/g15daemon/g15daemon-1.9.0.ebuild)4
6 files changed, 185 insertions, 3 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index d5271b0f5390..7a06ae398663 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/g15daemon
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.15 2007/05/01 10:31:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.16 2007/10/04 08:43:58 rbu Exp $
+
+*g15daemon-1.9.0-r1 (04 Oct 2007)
+*g15daemon-1.2.7-r1 (04 Oct 2007)
+
+ 04 Oct 2007; Robert Buchholz <rbu@gentoo.org>
+ +files/g15daemon-1.2.7-r1.initd, +g15daemon-1.2.7-r1.ebuild,
+ -g15daemon-1.9.0.ebuild, +g15daemon-1.9.0-r1.ebuild:
+ New POSIX init script by Peter Alfredsen and Roy Marples (bug #194365).
01 May 2007; Markus Rothe <corsair@gentoo.org> g15daemon-1.2.7.ebuild:
Stable on ppc64; bug #175120
diff --git a/app-misc/g15daemon/files/digest-g15daemon-1.2.7-r1 b/app-misc/g15daemon/files/digest-g15daemon-1.2.7-r1
new file mode 100644
index 000000000000..f40663c0ddfd
--- /dev/null
+++ b/app-misc/g15daemon/files/digest-g15daemon-1.2.7-r1
@@ -0,0 +1,3 @@
+MD5 ab84b85dfd6e0819f7a5ed85eb8e2673 g15daemon-1.2.7.tar.bz2 275938
+RMD160 e6490c9b3200c89cf88c574459eef7562a500161 g15daemon-1.2.7.tar.bz2 275938
+SHA256 2f8cfa386c88e72dbb07c7112cbd943dbda4f56dd55d08a01c7bf9efd47d164f g15daemon-1.2.7.tar.bz2 275938
diff --git a/app-misc/g15daemon/files/digest-g15daemon-1.9.0 b/app-misc/g15daemon/files/digest-g15daemon-1.9.0-r1
index 0f5a8a3c5fe8..0f5a8a3c5fe8 100644
--- a/app-misc/g15daemon/files/digest-g15daemon-1.9.0
+++ b/app-misc/g15daemon/files/digest-g15daemon-1.9.0-r1
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.7-r1.initd b/app-misc/g15daemon/files/g15daemon-1.2.7-r1.initd
new file mode 100644
index 000000000000..4ab66102e46b
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.2.7-r1.initd
@@ -0,0 +1,40 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.2.7-r1.initd,v 1.1 2007/10/04 08:43:58 rbu Exp $
+
+# Init script for g15daemon
+
+depend() {
+ after hotplug
+ after usb
+ after modules
+}
+
+start() {
+ ebegin "Starting g15daemon"
+
+ # Does the input device already exist?
+ if [ -e /proc/modules -a ! -e /dev/input/uinput ]; then
+ # We can load modules, but uinput device does not exist
+ einfo "Loading uinput module"
+ /sbin/modprobe uinput > /dev/null 2> /dev/null
+ fi
+
+ local SWITCHKEY=""
+ [ "${CLIENT_SWITCH_L1}" = "yes" ] && SWITCHKEY="--switch"
+ start-stop-daemon --start --background --pidfile /var/run/g15daemon.pid \
+ --exec /usr/sbin/g15daemon -- ${SWITCHKEY}
+ eend $? "Failed to start g15daemon."
+}
+
+stop() {
+ ebegin "Stopping g15daemon"
+ local KILLOPT="-k"
+ if [ $BACKLIGHT_OFF = "yes" ]; then
+ KILLOPT="-K"
+ fi
+ /usr/sbin/g15daemon ${KILLOPT} >/dev/null 2> /dev/null&&wait `cat /var/run/g15daemon.pid` \
+ || start-stop-daemon --signal SIGKILL --stop --quiet --pidfile /var/run/g15daemon.pid
+ eend $?
+}
diff --git a/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild b/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..e07e1c93b5b6
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.7-r1.ebuild,v 1.1 2007/10/04 08:43:58 rbu Exp $
+
+inherit eutils linux-info perl-module python multilib
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="perl python"
+
+DEPEND="dev-libs/libusb
+ dev-libs/libdaemon
+ >=dev-libs/libg15-1.2.0
+ perl? ( >=dev-perl/Inline-0.4 )
+ python? ( dev-lang/python )"
+
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/GDGraph )"
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ linux_chkconfig_present INPUT_UINPUT
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ die "INPUT_UINPUT support not detected!"
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ uinput_check
+}
+
+src_unpack() {
+ unpack ${A}
+ if use perl; then
+ unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+ if use python; then
+ unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+ fi
+}
+
+src_compile() {
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} install || die "make install failed"
+
+ # remove odd docs installed my make
+ rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/xmodmaprc
+ doins contrib/xmodmap.sh
+ if use perl; then
+ doins contrib/testbindings.pl
+ fi
+
+ newconfd "${FILESDIR}/${P}.confd" ${PN}
+ newinitd "${FILESDIR}/${PF}.initd" ${PN}
+
+ if use perl; then
+ ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/G15Daemon-0.2"
+ docinto perl
+ perl-module_src_install
+ fi
+
+ if use python; then
+ ebegin "Installing Python Bindings (g15daemon.py)"
+ cd "${WORKDIR}/pyg15daemon"
+ python_version
+
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
+ doins g15daemon.py
+ docinto python
+ dodoc AUTHORS
+ fi
+
+ prepalldocs
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize "${ROOT}/usr/$(get_libdir)/python*/site-packages/g15daemon"
+ echo ""
+ fi
+
+ elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+ elog "This can be done with:"
+ elog "# /sbin/rc-update add g15daemon default"
+ elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
+ elog ""
+ elog "To have all new keys working in X11, you'll need create a "
+ elog "specific xmodmap in your home directory or edit the existent one."
+ elog ""
+ elog "Create the xmodmap:"
+ elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ elog ""
+ elog "Adding keycodes to an existing xmodmap:"
+ elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/g15daemon"
+ fi
+}
diff --git a/app-misc/g15daemon/g15daemon-1.9.0.ebuild b/app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild
index 9aaf33028b9f..3fef0817a7c4 100644
--- a/app-misc/g15daemon/g15daemon-1.9.0.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.0.ebuild,v 1.2 2007/03/12 22:14:57 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild,v 1.1 2007/10/04 08:43:58 rbu Exp $
inherit eutils linux-info perl-module python multilib
@@ -80,7 +80,7 @@ src_install() {
fi
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
- newinitd "${FILESDIR}/${PN}-1.2.7.initd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.2.7-r1.initd" ${PN}
if use perl; then
ebegin "Installing Perl Bindings (G15Daemon.pm)"