summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-21 15:07:39 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-21 15:07:39 +0000
commite535011466c95744ae60d9384550a4dab3a28579 (patch)
treedd128f05eb2e8b99f988a1247e7028d6a068c13a /app-misc/empty/empty-0.6.19b.ebuild
parentChange homepage (diff)
downloadgentoo-2-e535011466c95744ae60d9384550a4dab3a28579.tar.gz
gentoo-2-e535011466c95744ae60d9384550a4dab3a28579.tar.bz2
gentoo-2-e535011466c95744ae60d9384550a4dab3a28579.zip
Version bump
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-misc/empty/empty-0.6.19b.ebuild')
-rw-r--r--app-misc/empty/empty-0.6.19b.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/empty/empty-0.6.19b.ebuild b/app-misc/empty/empty-0.6.19b.ebuild
new file mode 100644
index 000000000000..4071d3df9577
--- /dev/null
+++ b/app-misc/empty/empty-0.6.19b.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/empty-0.6.19b.ebuild,v 1.1 2012/10/21 15:07:39 pinkbyte Exp $
+
+EAPI="4"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Small shell utility, similar to expect(1)"
+HOMEPAGE="http://empty.sourceforge.net"
+SRC_URI="mirror://sourceforge/empty/${P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+DEPEND=""
+RDEPEND="virtual/logger"
+
+src_prepare() {
+ epatch "${FILESDIR}/overflow-fixes.patch"
+ epatch "${FILESDIR}/${PN}-respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin empty
+ doman empty.1
+ dodoc README
+ use examples && dodoc -r examples
+}