summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-04-02 01:39:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-04-02 01:39:20 +0000
commitdc03a89b675c607ce5e5c1164ed1aecd4ed3f7c0 (patch)
treec5787ab44bdb75ef279adee270802b88e606ac30 /app-misc/dnetc
parentAdd fix from upstream for mv/i-3 test failure #264455 by Ryan Hill. (diff)
downloadgentoo-2-dc03a89b675c607ce5e5c1164ed1aecd4ed3f7c0.tar.gz
gentoo-2-dc03a89b675c607ce5e5c1164ed1aecd4ed3f7c0.tar.bz2
gentoo-2-dc03a89b675c607ce5e5c1164ed1aecd4ed3f7c0.zip
NMU version bump, adds Core i7 detection that I need.
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/dnetc')
-rw-r--r--app-misc/dnetc/ChangeLog10
-rw-r--r--app-misc/dnetc/dnetc-2.9101.509.ebuild77
2 files changed, 85 insertions, 2 deletions
diff --git a/app-misc/dnetc/ChangeLog b/app-misc/dnetc/ChangeLog
index d864209c77e9..77ae8d0ba83c 100644
--- a/app-misc/dnetc/ChangeLog
+++ b/app-misc/dnetc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/dnetc
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.52 2008/12/31 05:36:45 darkside Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.53 2009/04/02 01:39:20 robbat2 Exp $
+
+*dnetc-2.9101.509 (02 Apr 2009)
+
+ 02 Apr 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +dnetc-2.9101.509.ebuild:
+ NMU version bump, adds Core i7 detection that I need.
*dnetc-2.9101.507 (31 Dec 2008)
diff --git a/app-misc/dnetc/dnetc-2.9101.509.ebuild b/app-misc/dnetc/dnetc-2.9101.509.ebuild
new file mode 100644
index 000000000000..fde3d73dc2b0
--- /dev/null
+++ b/app-misc/dnetc/dnetc-2.9101.509.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9101.509.ebuild,v 1.1 2009/04/02 01:39:20 robbat2 Exp $
+
+inherit eutils
+
+MAJ_PV=${PV:0:6}
+MIN_PV=${PV:7:9}
+
+DESCRIPTION="distributed.net client"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )
+ amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64-elf.tar.gz )"
+
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="net-dns/bind-tools"
+
+if use amd64; then
+ S="${WORKDIR}/dnetc${MIN_PV}-linux-amd64-elf"
+elif use x86; then
+ S="${WORKDIR}/dnetc${MIN_PV}-linux-x86-elf-uclibc"
+fi
+
+src_install() {
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc docs/CHANGES.txt docs/dnetc.txt docs/readme.*
+
+ newinitd "${FILESDIR}"/dnetc.initd dnetc
+ newconfd "${FILESDIR}"/dnetc.confd dnetc
+}
+
+pkg_preinst() {
+ if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
+ einfo "flushing old buffers"
+ source /etc/conf.d/dnetc
+
+ if [ -e /opt/distributed.net/dnetc.ini ]; then
+ # use ini file
+ /opt/distributed.net/dnetc -quiet -ini /opt/distributed.net/dnetc.ini -flush
+ elif [ ! -e /opt/distributed.net/dnetc.ini ] && [ ! -z ${EMAIL} ]; then
+ # email adress from config
+ /opt/distributed.net/dnetc -quiet -flush -e ${EMAIL}
+ fi
+
+ einfo "removing old buffer files"
+ rm -f /opt/distributed.net/buff*
+ fi
+
+ enewgroup dnetc
+ enewuser dnetc -1 -1 /opt/distributed.net dnetc
+}
+
+pkg_postinst() {
+ chown -Rf dnetc:dnetc /opt/distributed.net
+ chmod 0555 /opt/distributed.net/dnetc
+
+ elog "To run distributed.net client in the background at boot:"
+ elog " rc-update add dnetc default"
+ elog ""
+ elog "Either configure your email address in /etc/conf.d/dnetc"
+ elog "or create the configuration file /opt/distributed.net/dnetc.ini"
+}
+
+pkg_postrm() {
+ if [ -d /opt/distributed.net ]; then
+ elog "All files has not been removed from /opt/distributed.net"
+ fi
+}