summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-10-06 09:46:11 +0000
committerMichael Weber <xmw@gentoo.org>2012-10-06 09:46:11 +0000
commit6d27e32ecdc76e6fbcc68541b1eaf37e8b72cc7d (patch)
tree04340bda8cc787a85d141358389afead102c84ee /app-laptop
parentarm stable, bug #427544 (diff)
downloadgentoo-2-6d27e32ecdc76e6fbcc68541b1eaf37e8b72cc7d.tar.gz
gentoo-2-6d27e32ecdc76e6fbcc68541b1eaf37e8b72cc7d.tar.bz2
gentoo-2-6d27e32ecdc76e6fbcc68541b1eaf37e8b72cc7d.zip
Version bump (euscan), drop old patches
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/ChangeLog7
-rw-r--r--app-laptop/thinkfan/thinkfan-0.8.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-laptop/thinkfan/ChangeLog b/app-laptop/thinkfan/ChangeLog
index ecf11d883ff3..4fdc21f1e9e2 100644
--- a/app-laptop/thinkfan/ChangeLog
+++ b/app-laptop/thinkfan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/thinkfan
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.8 2012/06/23 23:18:19 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.9 2012/10/06 09:46:10 xmw Exp $
+
+*thinkfan-0.8.1 (06 Oct 2012)
+
+ 06 Oct 2012; Michael Weber <xmw@gentoo.org> +thinkfan-0.8.1.ebuild:
+ Version bump (euscan), drop old patches
23 Jun 2012; Michael Weber <xmw@gentoo.org> -thinkfan-0.8_alpha2.ebuild:
Drop old
diff --git a/app-laptop/thinkfan/thinkfan-0.8.1.ebuild b/app-laptop/thinkfan/thinkfan-0.8.1.ebuild
new file mode 100644
index 000000000000..55cb52812677
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/thinkfan-0.8.1.ebuild,v 1.1 2012/10/06 09:46:11 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd rcscripts/thinkfan.gentoo ${PN}
+
+ doman ${PN}.1
+ dodoc ChangeLog NEWS README \
+ examples/${PN}.conf.{complex,sysfs,thinkpad}
+}
+
+pkg_postinst() {
+ elog "Please read the documentation and copy an"
+ elog "appropriate file to /etc/thinkfan.conf."
+}