summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-07-12 04:22:22 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-07-12 04:22:22 +0000
commit5fa8a44084c4df4fa80238ecc173d9804a35eebc (patch)
tree617c9efcb8b44c67b55fa85de523303fa00b5601 /app-laptop
parentstable on mips (diff)
downloadgentoo-2-5fa8a44084c4df4fa80238ecc173d9804a35eebc.tar.gz
gentoo-2-5fa8a44084c4df4fa80238ecc173d9804a35eebc.tar.bz2
gentoo-2-5fa8a44084c4df4fa80238ecc173d9804a35eebc.zip
Added check for INPUT_EVDEV for bug #98050.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog5
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild16
2 files changed, 18 insertions, 3 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index d3c343035b54..b7761fe9afe4 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.26 2005/07/11 22:41:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.27 2005/07/12 04:22:22 josejx Exp $
+
+ 12 Jul 2005; Joseph Jezak <josejx@gentoo.org> pbbuttonsd-0.7.0.ebuild:
+ Added check for INPUT_EVDEV for bug #98050.
*pbbuttonsd-0.7.0 (11 Jul 2005)
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild
index d23f4ee9f5d4..eaa5f546b9f2 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild,v 1.1 2005/07/11 22:41:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild,v 1.2 2005/07/12 04:22:22 josejx Exp $
-inherit eutils
+inherit eutils linux-info
DESCRIPTION="program to map special Powerbook/iBook keys"
HOMEPAGE="http://pbbuttons.sf.net"
@@ -18,6 +18,12 @@ DEPEND="virtual/libc
RDEPEND=""
src_compile() {
+ if ! linux_chkconfig_present INPUT_EVDEV ; then
+ eerror "Please enable CONFIG_INPUT_EVDEV in your kernel"
+ eerror "pbbuttonsd will not work without it."
+ die "Kernel not compiled with CONFIG_INPUT_EVDEV support"
+ fi
+
econf || die "Sorry, failed to configure pbbuttonsd"
emake || die "Sorry, failed to compile pbbuttonsd"
}
@@ -31,6 +37,12 @@ src_install() {
}
pkg_postinst() {
+ if linux_chkconfig_module INPUT_EVDEV ; then
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ fi
+
+ einfo
einfo "This version of pbbuttonsd can replace PMUD functionality."
einfo "If you want PMUD installed and running, you should set"
einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"