summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-12-18 06:24:31 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-12-18 06:24:31 +0000
commit5f26c28ab948b1ea4fc230b9604390f0f2e34642 (patch)
tree885c2e5d13d04192f75eefb9ecd06b8127752963 /app-laptop
parentVersion bump to 2.6.20_rc1-r5 (diff)
downloadgentoo-2-5f26c28ab948b1ea4fc230b9604390f0f2e34642.tar.gz
gentoo-2-5f26c28ab948b1ea4fc230b9604390f0f2e34642.tar.bz2
gentoo-2-5f26c28ab948b1ea4fc230b9604390f0f2e34642.zip
Added patch to enable -lm to fix compile error without alsa. Thanks to gothgirl for pointing it out.
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog7
-rw-r--r--app-laptop/pbbuttonsd/files/lm-fix.patch11
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index c89bb112d973..55365ca16d5d 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.58 2006/12/17 02:05:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.59 2006/12/18 06:24:31 josejx Exp $
+
+ 18 Dec 2006; Joseph Jezak <josejx@gentoo.org> +files/lm-fix.patch,
+ pbbuttonsd-0.7.9.ebuild:
+ Added patch to enable -lm to fix compile error without alsa. Thanks to
+ gothgirl for pointing it out.
17 Dec 2006; Joseph Jezak <josejx@gentoo.org> files/x86-fix.patch:
Fixed the x86 patch for ppc.
diff --git a/app-laptop/pbbuttonsd/files/lm-fix.patch b/app-laptop/pbbuttonsd/files/lm-fix.patch
new file mode 100644
index 000000000000..1b767b8d47df
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/lm-fix.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in.old 2006-12-18 01:17:22.000000000 -0500
++++ src/Makefile.in 2006-12-18 01:17:33.000000000 -0500
+@@ -132,7 +132,7 @@
+ DEFS = @DEFS@ -I. -I$(srcdir) -I..
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@
++LIBS = -lm @LIBS@
+ pbbuttonsd_OBJECTS = pbbuttonsd.o init.o input_manager.o support.o \
+ config_manager.o module_pmac.o module_system.o module_powersave.o \
+ module_display.o module_cdrom.o module_mixer.o module_ossmixer.o \
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
index 67bbfe2469a7..d045e93e423e 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild,v 1.3 2006/12/17 01:42:46 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild,v 1.4 2006/12/18 06:24:31 josejx Exp $
inherit autotools flag-o-matic
@@ -22,6 +22,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch "${FILESDIR}/x86-fix.patch"
+ epatch "${FILESDIR}/lm-fix.patch"
eautoconf
}