summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-08-27 20:17:42 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-08-27 20:17:42 +0000
commit4a788e573ce1412870bfb29ef8457bd95a64ea78 (patch)
treeb98e59754d2eced1aba7464382b54f0637a4dc9e /app-laptop
parentTHanks to Fabian Groffen, closed #109949 (diff)
downloadgentoo-2-4a788e573ce1412870bfb29ef8457bd95a64ea78.tar.gz
gentoo-2-4a788e573ce1412870bfb29ef8457bd95a64ea78.tar.bz2
gentoo-2-4a788e573ce1412870bfb29ef8457bd95a64ea78.zip
make ibam really optional
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog6
-rw-r--r--app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch36
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild5
3 files changed, 45 insertions, 2 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 9e46eba541ca..8eafc8a76014 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.52 2006/08/26 07:23:19 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.53 2006/08/27 20:17:42 lu_zero Exp $
+
+ 27 Aug 2006; Luca Barbato <lu_zero@gentoo.org>
+ +files/pbbuttonsd-ibam-g++.patch, pbbuttonsd-0.7.8.ebuild:
+ fix spurious libstdc++ dep
26 Aug 2006; Stephanie Lockwood-Childs <wormo@gentoo.org>
+files/pbbuttonsd-laptopmode-noatime.patch, pbbuttonsd-0.6.6.ebuild,
diff --git a/app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch b/app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch
new file mode 100644
index 000000000000..85000783838c
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/pbbuttonsd-ibam-g++.patch
@@ -0,0 +1,36 @@
+--- pbbuttonsd-0.7.8.orig/configure.in 2006-07-31 10:08:31.000000000 +0200
++++ pbbuttonsd-0.7.8/configure.in 2006-08-27 21:36:25.000000000 +0200
+@@ -81,9 +81,7 @@
+ pbb_with_ibam=yes
+ AC_ARG_WITH(ibam, [ --with-ibam enable IBAM support in pbbuttonsd (default=yes)],
+ pbb_with_ibam=$withval, )
+-if test "$pbb_with_ibam" == "yes"; then
+- AC_DEFINE_UNQUOTED(WITH_IBAM, 1, [enable IBAM support])
+-fi
++AM_CONDITIONAL(WITH_IBAM, test "$pbb_with_ibam" = yes)
+
+ dnl Conditionals
+ AM_CONDITIONAL(DEBUG, test "$enable_debug" = yes)
+--- pbbuttonsd-0.7.8.orig/src/Makefile.am 2006-07-22 19:25:39.000000000 +0200
++++ pbbuttonsd-0.7.8/src/Makefile.am 2006-08-27 21:40:53.000000000 +0200
+@@ -4,6 +4,10 @@
+
+ bin_PROGRAMS = pbbuttonsd
+
++if WITH_IBAM
++IBAM = ibam_stub.cpp ibam_stub.h ibam.hpp ibam.inl
++endif
++
+ pbbuttonsd_SOURCES = \
+ pbbuttonsd.c \
+ init.c init.h systems.h \
+@@ -20,8 +24,7 @@
+ module_alsamixer.c module_alsamixer.h \
+ module_peep.c module_peep.h \
+ tcp.c tcp.h gettext_macros.h pbbinput.h \
+- debug.h \
+- ibam_stub.cpp ibam_stub.h ibam.hpp ibam.inl
++ debug.h $(IBAM)
+
+ pbbuttonsd_LDADD = -lpbb $(INTLLIBS) $(ALSA_LIBS) @PACKAGE_LIBS@
+ pbbuttonsd_LDFLAGS = -L$(top_srcdir)/libpbbipc
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild
index 46d779c8000d..fc62ebbcd1bc 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild,v 1.2 2006/08/26 07:23:19 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild,v 1.3 2006/08/27 20:17:42 lu_zero Exp $
inherit eutils flag-o-matic
@@ -22,6 +22,9 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PN}-laptopmode-noatime.patch
+ epatch ${FILESDIR}/${PN}-ibam-g++.patch
+ autoconf
+ automake
}
src_compile() {