summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 04:13:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 04:13:05 +0000
commit2a3bd43f7536032deb5d91fe3ad818fac0968474 (patch)
tree33bbe50e17fbd8718b6776d20e326758e2a2c8f9 /app-laptop
parentadd inherit eutils (diff)
downloadgentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.tar.gz
gentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.tar.bz2
gentoo-2-2a3bd43f7536032deb5d91fe3ad818fac0968474.zip
add inherit eutils
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tpb/tpb-0.6.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-laptop/tpb/tpb-0.6.1.ebuild b/app-laptop/tpb/tpb-0.6.1.ebuild
index 24c5ad9bba99..f85487f7bbc4 100644
--- a/app-laptop/tpb/tpb-0.6.1.ebuild
+++ b/app-laptop/tpb/tpb-0.6.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpb/tpb-0.6.1.ebuild,v 1.1 2004/03/31 01:10:52 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpb/tpb-0.6.1.ebuild,v 1.2 2004/04/06 04:08:19 vapier Exp $
+
+inherit eutils
DESCRIPTION="Thinkpad button utility"
HOMEPAGE="http://savannah.nongnu.org/projects/tpb/"
@@ -21,10 +23,7 @@ src_unpack() {
}
src_compile() {
- local myconf
-
- econf ${myconf} `use_enable nls`
-
+ econf `use_enable nls` || die
emake || die
}
@@ -32,6 +31,7 @@ src_install() {
make DESTDIR=${D} install || die
dodoc README ChangeLog CREDITS doc/{nvram.txt,callback_example.sh}
}
+
pkg_postinst() {
einfo "tpb requires you to have nvram support compiled into"
einfo "your kernel to function."