summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-20 04:58:41 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-12-20 04:58:41 +0000
commit8e81d0a0b5cce09d45a7c2635bcab2788d66c4d4 (patch)
treee6aa25a86e4a84356dae37d1c5b3f56431e678db /app-laptop/tpacpi-bat
parentupdated metadata.xml (diff)
downloadgentoo-2-8e81d0a0b5cce09d45a7c2635bcab2788d66c4d4.tar.gz
gentoo-2-8e81d0a0b5cce09d45a7c2635bcab2788d66c4d4.tar.bz2
gentoo-2-8e81d0a0b5cce09d45a7c2635bcab2788d66c4d4.zip
added release version
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'app-laptop/tpacpi-bat')
-rw-r--r--app-laptop/tpacpi-bat/ChangeLog8
-rw-r--r--app-laptop/tpacpi-bat/metadata.xml2
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-1.0.ebuild34
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild21
4 files changed, 55 insertions, 10 deletions
diff --git a/app-laptop/tpacpi-bat/ChangeLog b/app-laptop/tpacpi-bat/ChangeLog
index 10641b62bce2..eae7478fd3a5 100644
--- a/app-laptop/tpacpi-bat/ChangeLog
+++ b/app-laptop/tpacpi-bat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/tpacpi-bat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/ChangeLog,v 1.1 2012/12/09 21:29:30 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/ChangeLog,v 1.2 2012/12/20 04:58:41 ottxor Exp $
+
+*tpacpi-bat-1.0 (20 Dec 2012)
+
+ 20 Dec 2012; Christoph Junghans <ottxor@gentoo.org> +tpacpi-bat-1.0.ebuild,
+ metadata.xml, tpacpi-bat-9999.ebuild:
+ added release version
*tpacpi-bat-9999 (09 Dec 2012)
diff --git a/app-laptop/tpacpi-bat/metadata.xml b/app-laptop/tpacpi-bat/metadata.xml
index b4e68347fc62..730a6cdcb702 100644
--- a/app-laptop/tpacpi-bat/metadata.xml
+++ b/app-laptop/tpacpi-bat/metadata.xml
@@ -6,6 +6,6 @@
<name>Christoph Junghans</name>
</maintainer>
<upstream>
- <remote-id type="github">teleshoes/tpbattstat-applet</remote-id>
+ <remote-id type="github">teleshoes/tpacpi-bat</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-1.0.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-1.0.ebuild
new file mode 100644
index 000000000000..559bc4c8a28c
--- /dev/null
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/tpacpi-bat-1.0.ebuild,v 1.1 2012/12/20 04:58:40 ottxor Exp $
+
+EAPI=5
+
+inherit eutils
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/teleshoes/tpacpi-bat/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+DESCRIPTION="Control battery thresholds of recent ThinkPads, which are not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-power/acpi_call
+ dev-lang/perl"
+
+src_install() {
+ dodoc README battery_asl
+ dobin tpacpi-bat
+ newinitd "${FILESDIR}"/${PN}.initd.0 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
+}
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
index e651dfd572f0..a2185127d58f 100644
--- a/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
@@ -1,20 +1,25 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild,v 1.1 2012/12/09 21:29:30 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild,v 1.2 2012/12/20 04:58:40 ottxor Exp $
EAPI=5
-inherit eutils git-2
+inherit eutils
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/teleshoes/tpacpi-bat/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
DESCRIPTION="Control battery thresholds of recent ThinkPads, which are not supported by tp_smapi"
-HOMEPAGE="https://github.com/teleshoes/tpbattstat-applet"
-SRC_URI=""
-EGIT_REPO_URI="git://github.com/teleshoes/tpbattstat-applet.git"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-
IUSE=""
DEPEND=""
@@ -22,7 +27,7 @@ RDEPEND="sys-power/acpi_call
dev-lang/perl"
src_install() {
- dodoc README.md AUTHORS
+ dodoc README battery_asl
dobin tpacpi-bat
newinitd "${FILESDIR}"/${PN}.initd.0 ${PN}
newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}