summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-10-05 17:46:10 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-10-05 17:46:10 +0000
commita5028851da44f6fb4fa1bf5f599862922f9fc23a (patch)
tree04c1fb76ce9e40d1ac369e3bc38ccf667ad871a0 /app-laptop/pbbuttonsd
parentUse "egethome ftp" instead of greping and cuting /etc/passwd. (diff)
downloadgentoo-2-a5028851da44f6fb4fa1bf5f599862922f9fc23a.tar.gz
gentoo-2-a5028851da44f6fb4fa1bf5f599862922f9fc23a.tar.bz2
gentoo-2-a5028851da44f6fb4fa1bf5f599862922f9fc23a.zip
New version, forced -O1 to fix lockup issue reported in the forums, thanks HighOnBonsai.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog8
-rw-r--r--app-laptop/pbbuttonsd/Manifest6
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.21
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild68
4 files changed, 80 insertions, 3 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 489960fcc7c4..ea923536dfe7 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.34 2005/09/25 15:34:57 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.35 2005/10/05 17:46:10 josejx Exp $
+
+*pbbuttonsd-0.7.2 (05 Oct 2005)
+
+ 05 Oct 2005; Joseph Jezak <josejx@gentoo.org> +pbbuttonsd-0.7.2.ebuild:
+ New version, forced -O1 to fix lockup issue reported in the forums, thanks
+ HighOnBonsai.
25 Sep 2005; Luca Barbato <lu_zero@gentoo.org> files/pbbuttonsd.rc6:
Minor fix to support parallel init
diff --git a/app-laptop/pbbuttonsd/Manifest b/app-laptop/pbbuttonsd/Manifest
index 478415076f0b..6d7b07be6b7d 100644
--- a/app-laptop/pbbuttonsd/Manifest
+++ b/app-laptop/pbbuttonsd/Manifest
@@ -1,7 +1,9 @@
+MD5 f5c7489373340970b2f01c0372b1ac3c ChangeLog 9522
MD5 7b9b4d9f5e7b4fde48b4597c4ba8cf06 pbbuttonsd-0.6.6.ebuild 1140
-MD5 bd51d9aa7f1c2f34debf41dce4cf5e38 ChangeLog 9321
MD5 52f9d8e98c8931645c57a3de1c36727d metadata.xml 156
+MD5 4e037a0b8b19b0350570c31408a03ffd pbbuttonsd-0.7.2.ebuild 1831
MD5 2430cccf9363cdd529dcef6d66112317 pbbuttonsd-0.7.1.ebuild 1764
MD5 bfeca35f0f0f5c946cec186998f304e2 files/pbbuttonsd.rc6 472
-MD5 72caa2adac6c8260c57c0ae15cc259f3 files/digest-pbbuttonsd-0.6.6 68
+MD5 d0c2afca8a18bbfdc406106d85d30193 files/digest-pbbuttonsd-0.7.2 68
MD5 0d5e37ab33c0a4177affbe953a76f8f3 files/digest-pbbuttonsd-0.7.1 68
+MD5 72caa2adac6c8260c57c0ae15cc259f3 files/digest-pbbuttonsd-0.6.6 68
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.2 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.2
new file mode 100644
index 000000000000..ee6f96d02eb7
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.2
@@ -0,0 +1 @@
+MD5 22b4fba5874452f12a3fee01d7b16710 pbbuttonsd-0.7.2.tar.gz 403797
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild
new file mode 100644
index 000000000000..55439b2defa3
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild,v 1.1 2005/10/05 17:46:10 josejx Exp $
+
+inherit eutils linux-info flag-o-matic
+
+DESCRIPTION="program to map special Powerbook/iBook keys"
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="acpi debug"
+
+DEPEND="virtual/libc
+ >=sys-apps/baselayout-1.8.6.12-r1"
+RDEPEND=""
+
+src_compile() {
+ # Fix crash bug on some systems
+ replace-flags -O? -O1
+
+ if ! linux_chkconfig_present INPUT_EVDEV ; then
+ eerror "Please enable CONFIG_INPUT_EVDEV in your kernel"
+ eerror "pbbuttonsd will not work without it."
+ die "Kernel not compiled with CONFIG_INPUT_EVDEV support"
+ fi
+
+ if use x86; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop \
+ $(use_enable debug) || die "Sorry, failed to configure pbbuttonsd"
+ emake || die "Sorry, failed to compile pbbuttonsd"
+}
+
+src_install() {
+ dodir /etc/power
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+}
+
+pkg_postinst() {
+ if linux_chkconfig_module INPUT_EVDEV ; then
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ fi
+
+ if use ppc; then
+ einfo
+ einfo "This version of pbbuttonsd can replace PMUD functionality."
+ einfo "If you want PMUD installed and running, you should set"
+ einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"
+ einfo "try setting replace_pmud=yes in /etc/pbbuttonsd.conf and"
+ einfo "disabling PMUD"
+ ewarn "Warning: the NoTapTyping option is unstable, see bug #86768."
+ fi
+}