summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-08-20 16:13:18 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-08-20 16:13:18 +0000
commit8ad5440b39d64754194732327d91cdcf581464bf (patch)
tree4ffc4b5bfae3c123dd4ca920aa84a68cb0d4abbd /app-i18n
parentVersion bump. Removed version 3.3 because of upstream critical bugs. (diff)
downloadgentoo-2-8ad5440b39d64754194732327d91cdcf581464bf.tar.gz
gentoo-2-8ad5440b39d64754194732327d91cdcf581464bf.tar.bz2
gentoo-2-8ad5440b39d64754194732327d91cdcf581464bf.zip
Fixed compile issue, bug #108680 and #189555.
(Portage version: 2.1.2.11)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/xsim/ChangeLog8
-rw-r--r--app-i18n/xsim/files/digest-xsim-0.3.9.4-r43
-rw-r--r--app-i18n/xsim/files/xsim-0.3.9.4-64bit.patch57
-rw-r--r--app-i18n/xsim/xsim-0.3.9.4-r4.ebuild80
4 files changed, 147 insertions, 1 deletions
diff --git a/app-i18n/xsim/ChangeLog b/app-i18n/xsim/ChangeLog
index f664ae88a34d..58600daced44 100644
--- a/app-i18n/xsim/ChangeLog
+++ b/app-i18n/xsim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/xsim
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/ChangeLog,v 1.14 2007/02/21 22:16:03 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/ChangeLog,v 1.15 2007/08/20 16:13:18 matsuu Exp $
+
+*xsim-0.3.9.4-r4 (20 Aug 2007)
+
+ 20 Aug 2007; MATSUU Takuto <matsuu@gentoo.org>
+ +files/xsim-0.3.9.4-64bit.patch, +xsim-0.3.9.4-r4.ebuild:
+ Fixed compile issue, bug #108680 and #189555.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-i18n/xsim/files/digest-xsim-0.3.9.4-r4 b/app-i18n/xsim/files/digest-xsim-0.3.9.4-r4
new file mode 100644
index 000000000000..9142ac631814
--- /dev/null
+++ b/app-i18n/xsim/files/digest-xsim-0.3.9.4-r4
@@ -0,0 +1,3 @@
+MD5 645d68ee8c565c04782068c4546504d9 xsim-0.3.9.4.tar.gz 1025640
+RMD160 9b5d0106448a3311047d3fe4a8fad0852ca2dca0 xsim-0.3.9.4.tar.gz 1025640
+SHA256 048f23527543b21c4d52dc98967ec7253c34eb704056767364c6dc5007971b2c xsim-0.3.9.4.tar.gz 1025640
diff --git a/app-i18n/xsim/files/xsim-0.3.9.4-64bit.patch b/app-i18n/xsim/files/xsim-0.3.9.4-64bit.patch
new file mode 100644
index 000000000000..3b6f0f5d06a5
--- /dev/null
+++ b/app-i18n/xsim/files/xsim-0.3.9.4-64bit.patch
@@ -0,0 +1,57 @@
+diff -Naur xsim-0.3.9.4.orig/plugins/IMs/jianpin/simpleimc.h xsim-0.3.9.4/plugins/IMs/jianpin/simpleimc.h
+--- xsim-0.3.9.4.orig/plugins/IMs/jianpin/simpleimc.h 2002-10-22 18:01:04.000000000 +0900
++++ xsim-0.3.9.4/plugins/IMs/jianpin/simpleimc.h 2007-08-20 23:15:06.000000000 +0900
+@@ -45,7 +45,7 @@
+ uint16_t access_count;
+ wchar_t w[MAX_WORD_LEN + 1];
+
+- size_t ac_size() { return (uint32_t) w - (uint32_t)&access_count; }
++ size_t ac_size() { return (size_t) w - (size_t)&access_count; }
+ size_t size(){ return ac_size() + wcslen(w) * sizeof(wchar_t); }
+ void copy(struct Word_Rec_tag * val) { memcpy(this, val, sizeof(Word_Rec_tag));}
+ }Word_Rec;
+diff -Naur xsim-0.3.9.4.orig/plugins/IMs/table/tableimc.h xsim-0.3.9.4/plugins/IMs/table/tableimc.h
+--- xsim-0.3.9.4.orig/plugins/IMs/table/tableimc.h 2002-09-13 20:34:03.000000000 +0900
++++ xsim-0.3.9.4/plugins/IMs/table/tableimc.h 2007-08-20 23:15:47.000000000 +0900
+@@ -23,7 +23,7 @@
+ uint8_t sort_index;
+ wchar_t w[MAX_WORD_LEN + 1];
+
+- size_t si_size() { return (uint32_t) w - (uint32_t)&sort_index; }
++ size_t si_size() { return (size_t) w - (size_t)&sort_index; }
+ size_t size(){ return si_size() + (wcslen(w) + 1) * sizeof(wchar_t); }
+ void copy(struct Word_Rec_tag * val) { memcpy(this, val, sizeof(Word_Rec_tag));}
+ }Word_Rec;
+diff -Naur xsim-0.3.9.4.orig/xsim/ic.cpp xsim-0.3.9.4/xsim/ic.cpp
+--- xsim-0.3.9.4.orig/xsim/ic.cpp 2002-10-01 14:41:23.000000000 +0900
++++ xsim-0.3.9.4/xsim/ic.cpp 2007-08-20 23:16:11.000000000 +0900
+@@ -101,7 +101,7 @@
+ on_stat = 0;
+ }
+
+-int TIC::alive()
++long TIC::alive()
+ {
+- return (int)im;
++ return (long)im;
+ }
+diff -Naur xsim-0.3.9.4.orig/xsim/ic.h xsim-0.3.9.4/xsim/ic.h
+--- xsim-0.3.9.4.orig/xsim/ic.h 2002-07-15 00:14:24.000000000 +0900
++++ xsim-0.3.9.4/xsim/ic.h 2007-08-20 23:16:52.000000000 +0900
+@@ -76,14 +76,14 @@
+ void set_im(TIM * val);
+
+ TIMC * get_imc();
+- int has_imc() { return (int)imc; }
++ long has_imc() { return (long)imc; }
+
+ void init(int init_mode, TIM * val);
+
+ static TIC * get_focus_ic() { return focused_ic; }
+ IC * get_IC() { return &ic_; };
+
+- int alive();
++ long alive();
+ Window get_client_win() { return ic_.client_win; }
+
+ int has_focus() { return (focused_ic == this); }
diff --git a/app-i18n/xsim/xsim-0.3.9.4-r4.ebuild b/app-i18n/xsim/xsim-0.3.9.4-r4.ebuild
new file mode 100644
index 000000000000..823664a50b18
--- /dev/null
+++ b/app-i18n/xsim/xsim-0.3.9.4-r4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r4.ebuild,v 1.1 2007/08/20 16:13:18 matsuu Exp $
+
+inherit db-use eutils flag-o-matic kde-functions multilib
+
+DESCRIPTION="A simple and fast GB and BIG5 Chinese XIM server"
+HOMEPAGE="http://developer.berlios.de/projects/xsim/"
+SRC_URI="http://download.berlios.de/xsim/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kde"
+
+DEPEND=">=sys-libs/db-4.1
+ >=sys-apps/sed-4
+ kde? ( >=kde-base/kdelibs-3 )"
+
+src_unpack() {
+ local dbver
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-compile-fix.patch
+ epatch "${FILESDIR}"/${P}-gcc-3.4.patch
+ epatch "${FILESDIR}"/${P}-64bit.patch
+
+ append-flags -DPIC -fPIC -fno-strict-aliasing
+
+ dbver="$(db_findver sys-libs/db)"
+ sed -i -e "s/\(CFLAGS.*\)-O2/\1${CFLAGS}/" \
+ -e "s/libdb_cxx.so/libdb_cxx-${dbver}.so/" \
+ -e "s/bdblib=\"db_cxx\"/bdblib=\"db_cxx-${dbver}\"/" configure* || die
+
+ find . -name '*.in' | xargs sed -i \
+ -e "s#\(@prefix@/\)\(dat\|plugins\)#\1$(get_libdir)/xsim/\2#" \
+ -e "s#@prefix@/etc#/etc#" || die
+}
+
+src_compile() {
+ local myconf
+
+ if use kde; then
+ set-qtdir 3
+ set-kdedir 3
+ myconf="${myconf}
+ --with-kde3=${KDEDIR} \
+ --with-qt3=${QTDIR} \
+ --enable-status-kde3"
+ fi
+
+ myconf="${myconf} --with-bdb-includes=$(db_includedir)"
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake \
+ xsim_datp="${D}"/usr/$(get_libdir)/xsim/dat \
+ xsim_libp="${D}"usr/$(get_libdir)/xsim/plugins \
+ xsim_binp="${D}"/usr/bin \
+ xsim_etcp="${D}"/etc \
+ install-data install || die "install failed"
+
+ dodoc ChangeLog KNOWNBUG README* TODO
+}
+
+pkg_postinst() {
+ elog "XSIM needs write access to /usr/$(get_libdir)/xsim/dat/chardb, so if you"
+ elog "not running it as root, you need to do the following:"
+ elog
+ elog " cp -r /usr/$(get_libdir)/xsim/dat \${HOME}/.xsim"
+ elog " sed -i \"s#DICT_LOCAL.*#DICT_LOCAL \${HOME}/.xsim#\" > \${HOME}/.xsim/xsimrc"
+ echo
+}