summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-27 13:50:27 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-27 13:50:27 +0000
commit7a409b7c8361961dd076f01edc0ce10ebb839a35 (patch)
tree01d762fa5982d5db53640cc832316a5452c3d8ad /app-i18n
parentFix unsetting PYTHON. (diff)
downloadgentoo-2-7a409b7c8361961dd076f01edc0ce10ebb839a35.tar.gz
gentoo-2-7a409b7c8361961dd076f01edc0ce10ebb839a35.tar.bz2
gentoo-2-7a409b7c8361961dd076f01edc0ce10ebb839a35.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/libtomoe-gtk/ChangeLog8
-rw-r--r--app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r3.ebuild76
2 files changed, 82 insertions, 2 deletions
diff --git a/app-i18n/libtomoe-gtk/ChangeLog b/app-i18n/libtomoe-gtk/ChangeLog
index 423f3f2cc7b1..ac4296a2cb77 100644
--- a/app-i18n/libtomoe-gtk/ChangeLog
+++ b/app-i18n/libtomoe-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/libtomoe-gtk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtomoe-gtk/ChangeLog,v 1.20 2014/07/24 02:10:29 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtomoe-gtk/ChangeLog,v 1.21 2014/12/27 13:50:27 mgorny Exp $
+
+*libtomoe-gtk-0.6.0-r3 (27 Dec 2014)
+
+ 27 Dec 2014; Michał Górny <mgorny@gentoo.org> +libtomoe-gtk-0.6.0-r3.ebuild:
+ Convert to python-single-r1.
24 Jul 2014; Yixun Lan <dlan@gentoo.org> -libtomoe-gtk-0.6.0.ebuild,
-libtomoe-gtk-0.6.0-r1.ebuild:
@@ -98,4 +103,3 @@
12 Aug 2006; MATSUU Takuto <matsuu@gentoo.org> +libtomoe-gtk-0.1.0.ebuild:
Initial ebuild submitted by Olof <olofshopping@hotmail.com>. bug 140120.
-
diff --git a/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r3.ebuild b/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r3.ebuild
new file mode 100644
index 000000000000..b7a6ed98fd6f
--- /dev/null
+++ b/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtomoe-gtk/libtomoe-gtk-0.6.0-r3.ebuild,v 1.1 2014/12/27 13:50:27 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-single-r1
+
+MY_P="tomoe-gtk-${PV}"
+DESCRIPTION="Tomoe GTK+ interface widget library"
+HOMEPAGE="http://tomoe.sourceforge.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +gucharmap python static-libs"
+
+RDEPEND=">=app-i18n/tomoe-0.6.0
+ python? (
+ ${PYTHON_DEPS}
+ >=app-i18n/tomoe-0.6.0[python,${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ )
+ gucharmap? ( gnome-extra/gucharmap:0 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use python ; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Fix compilation with gucharmap-2.24, bug #243160
+ epatch "${FILESDIR}/${P}-gucharmap2.patch"
+ epatch "${FILESDIR}/${P}-underlinking.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ #--with-python b0rked hard
+ unset PYTHON
+ use python || myconf="${myconf} --without-python"
+
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_with gucharmap) \
+ $(use_enable static-libs static) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use python ; then
+ find "${D}$(python_get_sitedir)" \( -name "*.la" -o -name "*.a" \) -type f -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}