summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-01-29 15:12:01 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-01-29 15:12:01 +0000
commit7326d0aaa28ee9c66aa581fc9e2a6e7659b0ff04 (patch)
tree99c636bbf206746710d5af5ad15ad4f8946bbdda /app-i18n
parentFixed python-2.6 issue, #255210. Fixed KLineEdit issue. (diff)
downloadgentoo-2-7326d0aaa28ee9c66aa581fc9e2a6e7659b0ff04.tar.gz
gentoo-2-7326d0aaa28ee9c66aa581fc9e2a6e7659b0ff04.tar.bz2
gentoo-2-7326d0aaa28ee9c66aa581fc9e2a6e7659b0ff04.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy/ChangeLog9
-rw-r--r--app-i18n/anthy/anthy-9100g.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 298db6278ce9..99548cf87ae5 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.119 2008/07/31 10:03:35 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.120 2009/01/29 15:12:01 matsuu Exp $
+
+*anthy-9100g (29 Jan 2009)
+
+ 29 Jan 2009; MATSUU Takuto <matsuu@gentoo.org> +anthy-9100g.ebuild:
+ Version bumped.
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56. Add pkg tags in
diff --git a/app-i18n/anthy/anthy-9100g.ebuild b/app-i18n/anthy/anthy-9100g.ebuild
new file mode 100644
index 000000000000..4ce83cd0a438
--- /dev/null
+++ b/app-i18n/anthy/anthy-9100g.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-9100g.ebuild,v 1.1 2009/01/29 15:12:01 matsuu Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/37336/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+DEPEND="!app-i18n/anthy-ss
+ emacs? ( virtual/emacs )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ sed -i \
+ -e "/set_input_encoding eucjp/aread /var/lib/canna/dic/canna/nichan.ctd" \
+ mkworddic/dict.args.in || die
+ fi
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use emacs || myconf="EMACS=no"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+ dodoc AUTHORS DIARY NEWS README ChangeLog
+
+ docinto doc
+ rm doc/Makefile*
+ dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}