summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-08-18 02:49:58 +0000
committerNaohiro Aota <naota@gentoo.org>2011-08-18 02:49:58 +0000
commit2511acb11c8671b3ad12ac52f62ab821adb03f64 (patch)
tree058e2937de4336412c2ad2fbee55accd803966c6 /app-i18n
parentVersion bump; Add patch to drop cmake 2.6.x compatible statement (diff)
downloadgentoo-2-2511acb11c8671b3ad12ac52f62ab821adb03f64.tar.gz
gentoo-2-2511acb11c8671b3ad12ac52f62ab821adb03f64.tar.bz2
gentoo-2-2511acb11c8671b3ad12ac52f62ab821adb03f64.zip
Version bumped.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-input-pad/ChangeLog7
-rw-r--r--app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-i18n/scim-input-pad/ChangeLog b/app-i18n/scim-input-pad/ChangeLog
index d4c406edcb39..124bdba317b2 100644
--- a/app-i18n/scim-input-pad/ChangeLog
+++ b/app-i18n/scim-input-pad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-input-pad
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-input-pad/ChangeLog,v 1.7 2011/03/27 11:35:14 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-input-pad/ChangeLog,v 1.8 2011/08/18 02:49:58 naota Exp $
+
+*scim-input-pad-0.1.3 (18 Aug 2011)
+
+ 18 Aug 2011; Naohiro Aota <naota@gentoo.org> +scim-input-pad-0.1.3.ebuild:
+ Version bumped.
27 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
scim-input-pad-0.1.1.ebuild:
diff --git a/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild
new file mode 100644
index 000000000000..14c5314b8ba5
--- /dev/null
+++ b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild,v 1.1 2011/08/18 02:49:58 naota Exp $
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="Input pad for SCIM used to input symbols and special characters"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/scim-1.2.0
+ >=x11-libs/gtk+-2.6.0:2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls) || die "Error: econf failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Error: install failed!"
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+
+ elog
+ elog "The SCIM input pad should be startable from the SCIM (and Skim)"
+ elog "systray icon right click menu. You will have to restart SCIM"
+ elog "(or Skim) in order for the menu entry to appear (you may simply"
+ elog "restart your X server). If you want to use it immediately, just"
+ elog "start the SCIM input pad, using the 'scim-input-pad' command."
+ elog
+ elog "To use, select the text zone you wish to write in, and just"
+ elog "click on the wanted character in the right multilevel tabbed"
+ elog "table, from the SCIM Input Pad interface."
+ elog
+ elog "To add new characters to the tables, see the documentation"
+ elog "(README file in /usr/share/doc/${PF})."
+ elog
+
+}