summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-01-25 17:59:43 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-01-25 17:59:43 +0000
commit1afb42497bad15e4b23508be7eb031aeb6e51b86 (patch)
treeb5e3be67f0c565b3c0f5bcd438d72eb41b102987 /app-i18n/zhcon/zhcon-0.2.3-r1.ebuild
parentUse properly the kde eclasses, and do not install in KDEDIR. (diff)
downloadgentoo-2-1afb42497bad15e4b23508be7eb031aeb6e51b86.tar.gz
gentoo-2-1afb42497bad15e4b23508be7eb031aeb6e51b86.tar.bz2
gentoo-2-1afb42497bad15e4b23508be7eb031aeb6e51b86.zip
security patch for unauthorised file access (CAN-2005-0072) bug #78117
(Portage version: 2.0.51-r14)
Diffstat (limited to 'app-i18n/zhcon/zhcon-0.2.3-r1.ebuild')
-rw-r--r--app-i18n/zhcon/zhcon-0.2.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/zhcon/zhcon-0.2.3-r1.ebuild b/app-i18n/zhcon/zhcon-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..16214265c689
--- /dev/null
+++ b/app-i18n/zhcon/zhcon-0.2.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/zhcon-0.2.3-r1.ebuild,v 1.1 2005/01/25 17:59:43 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="A Fast CJK (Chinese/Japanese/Korean) Console Environment"
+HOMEPAGE="http://zhcon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zhcon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-devel/autoconf"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-assert-gentoo.diff
+ epatch ${FILESDIR}/${P}-gcc34.patch
+
+ # bug #78117 - unauthorized file acess CAN-2005-0072
+ epatch ${FILESDIR}/${P}-CAN-2005-0072.patch
+}
+
+src_compile() {
+ autoconf || die "autoconf failed"
+ econf || die
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}