summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-02-16 19:30:56 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-02-16 19:30:56 +0000
commit25951f4eb499dd9b8e433035f14625e055bfc29b (patch)
tree09a86f4c204eb923915dfbdc9cc2558fb2b2ed82 /app-i18n/scim-input-pad/scim-input-pad-0.1.1.ebuild
parentfix ChangeLog header (diff)
downloadgentoo-2-25951f4eb499dd9b8e433035f14625e055bfc29b.tar.gz
gentoo-2-25951f4eb499dd9b8e433035f14625e055bfc29b.tar.bz2
gentoo-2-25951f4eb499dd9b8e433035f14625e055bfc29b.zip
initial ebuild thanks to Mathieu Bonnet (#100599)
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-i18n/scim-input-pad/scim-input-pad-0.1.1.ebuild')
-rw-r--r--app-i18n/scim-input-pad/scim-input-pad-0.1.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-i18n/scim-input-pad/scim-input-pad-0.1.1.ebuild b/app-i18n/scim-input-pad/scim-input-pad-0.1.1.ebuild
new file mode 100644
index 000000000000..4688a739c22c
--- /dev/null
+++ b/app-i18n/scim-input-pad/scim-input-pad-0.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-input-pad/scim-input-pad-0.1.1.ebuild,v 1.1 2006/02/16 19:30:56 liquidx Exp $
+
+DESCRIPTION="Input pad for SCIM used to input symbols and special characters"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND=">=app-i18n/scim-1.2.0
+ >=x11-libs/gtk+-2.6.0"
+
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf $(use_enable nls) || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Error: install failed!"
+ dodoc ChangeLog README TODO
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "The SCIM input pad should be startable from the SCIM (and Skim)"
+ einfo "systray icon right click menu. You will have to restart SCIM"
+ einfo "(or Skim) in order for the menu entry to appear (you may simply"
+ einfo "restart your X server). If you want to use it immediately, just"
+ einfo "start the SCIM input pad, using the 'scim-input-pad' command."
+ einfo
+ einfo "To use, select the text zone you wish to write in, and just"
+ einfo "click on the wanted character in the right multilevel tabbed"
+ einfo "table, from the SCIM Input Pad interface."
+ einfo
+ einfo "To add new characters to the tables, see the documentation"
+ einfo "(/usr/share/doc/${PF}/README.gz)."
+ einfo
+
+}