summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-08-31 03:00:07 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-08-31 03:00:07 +0000
commit50c6a389db11ba65fcca07a1b818031718fa1469 (patch)
treec895183e2a16c53ef8e310b118f72ad3e8224b8e /app-i18n/kimera
parentclean out old ebuilds (diff)
downloadgentoo-2-50c6a389db11ba65fcca07a1b818031718fa1469.tar.gz
gentoo-2-50c6a389db11ba65fcca07a1b818031718fa1469.tar.bz2
gentoo-2-50c6a389db11ba65fcca07a1b818031718fa1469.zip
Version bumped.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-i18n/kimera')
-rw-r--r--app-i18n/kimera/ChangeLog8
-rw-r--r--app-i18n/kimera/files/kimera-2.00-gentoo.patch22
-rw-r--r--app-i18n/kimera/kimera-2.00.ebuild41
3 files changed, 70 insertions, 1 deletions
diff --git a/app-i18n/kimera/ChangeLog b/app-i18n/kimera/ChangeLog
index e80843623b90..2b30c43b25df 100644
--- a/app-i18n/kimera/ChangeLog
+++ b/app-i18n/kimera/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/kimera
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/ChangeLog,v 1.12 2008/07/31 10:12:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/ChangeLog,v 1.13 2008/08/31 03:00:07 matsuu Exp $
+
+*kimera-2.00 (31 Aug 2008)
+
+ 31 Aug 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/kimera-2.00-gentoo.patch, +kimera-2.00.ebuild:
+ Version bumped. cleanup
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-i18n/kimera/files/kimera-2.00-gentoo.patch b/app-i18n/kimera/files/kimera-2.00-gentoo.patch
new file mode 100644
index 000000000000..e70d660efbd3
--- /dev/null
+++ b/app-i18n/kimera/files/kimera-2.00-gentoo.patch
@@ -0,0 +1,22 @@
+diff -Naur kimera-2.00.orig/kimera.pro kimera-2.00/kimera.pro
+--- kimera-2.00.orig/kimera.pro 2008-08-30 22:05:31.000000000 +0900
++++ kimera-2.00/kimera.pro 2008-08-31 11:52:37.000000000 +0900
+@@ -1,5 +1,5 @@
+ TEMPLATE = app
+-CONFIG += qt x11 warn_on release
++CONFIG += qt x11 warn_on release nostrip
+ QT += network
+ TARGET = kimera-bin
+ VERSION = 2.00
+diff -Naur kimera-2.00.orig/src/inputmethod.cpp kimera-2.00/src/inputmethod.cpp
+--- kimera-2.00.orig/src/inputmethod.cpp 2008-08-30 22:05:31.000000000 +0900
++++ kimera-2.00/src/inputmethod.cpp 2008-08-31 11:43:44.000000000 +0900
+@@ -165,7 +165,7 @@
+ im, ic, flag, errcode, errtype, __FILE__, __LINE__);
+ if (errlen > 0) {
+ char errdetail[256] = { 0 };
+- dsbuf.readRawData((char*)errdetail, qMin((quint32)errlen, sizeof(errdetail) - 1)); // header
++ dsbuf.readRawData((char*)errdetail, qMin((quint32)errlen, (quint32)sizeof(errdetail) - 1)); // header
+ qDebug("Error detail: %s", errdetail);
+ }
+ }
diff --git a/app-i18n/kimera/kimera-2.00.ebuild b/app-i18n/kimera/kimera-2.00.ebuild
new file mode 100644
index 000000000000..7cfbc7bc945f
--- /dev/null
+++ b/app-i18n/kimera/kimera-2.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/kimera-2.00.ebuild,v 1.1 2008/08/31 03:00:07 matsuu Exp $
+
+EAPI=1
+inherit eutils multilib qt4
+
+DESCRIPTION="A Japanese input method which supports the XIM protocol"
+SRC_URI="mirror://sourceforge.jp/kimera/32701/${P}.tar.gz"
+HOMEPAGE="http://kimera.sourceforge.jp/"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+anthy"
+
+DEPEND="|| ( x11-libs/qt-core:4 x11-libs/qt:4 )
+ anthy? ( app-i18n/anthy )
+ !anthy? ( app-i18n/canna )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ local myconf="target.path=/usr/$(get_libdir)/${P}"
+
+ use anthy || myconf="${myconf} no_anthy=1"
+
+ eqmake4 kimera.pro ${myconf} || die
+ emake || die
+}
+
+src_install(){
+ emake INSTALL_ROOT="${D}" install || die
+
+ dodoc AUTHORS README*
+}