summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Bouyer <stubear@gentoo.org>2002-10-28 13:27:58 +0000
committerStuart Bouyer <stubear@gentoo.org>2002-10-28 13:27:58 +0000
commit7f483710b6369cf90c8d9234ee1d2703e90bf6ba (patch)
tree2d7fe9943072da675f2fe1954000e361975e8726 /app-i18n/kcc
parentNew version (diff)
downloadgentoo-2-7f483710b6369cf90c8d9234ee1d2703e90bf6ba.tar.gz
gentoo-2-7f483710b6369cf90c8d9234ee1d2703e90bf6ba.tar.bz2
gentoo-2-7f483710b6369cf90c8d9234ee1d2703e90bf6ba.zip
intial ebuild submission
Diffstat (limited to 'app-i18n/kcc')
-rw-r--r--app-i18n/kcc/files/digest-kcc-1.01
-rw-r--r--app-i18n/kcc/files/kcc-1.0/gentoo.diff25
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild36
3 files changed, 62 insertions, 0 deletions
diff --git a/app-i18n/kcc/files/digest-kcc-1.0 b/app-i18n/kcc/files/digest-kcc-1.0
new file mode 100644
index 000000000000..0dc61ab74617
--- /dev/null
+++ b/app-i18n/kcc/files/digest-kcc-1.0
@@ -0,0 +1 @@
+MD5 ae22fdd91b6160f6cfe322e33fb1502f kcc.tar.gz 18869
diff --git a/app-i18n/kcc/files/kcc-1.0/gentoo.diff b/app-i18n/kcc/files/kcc-1.0/gentoo.diff
new file mode 100644
index 000000000000..26f3a92b37a9
--- /dev/null
+++ b/app-i18n/kcc/files/kcc-1.0/gentoo.diff
@@ -0,0 +1,25 @@
+--- Makefile.orig Sat Aug 3 18:44:55 2002
++++ Makefile Sat Aug 3 18:45:57 2002
+@@ -7,8 +7,8 @@
+
+ # @(#)Makefile 2.3 (Y.Tonooka) 3/28/94
+
+- BINPATH = /usr/local/bin
+- MANPATH = /usr/local/man
++ BINPATH = $(DESTDIR)/usr/bin
++ MANPATH = $(DESTDIR)/usr/man
+ JMANDIR = japanese
+ CFLAGS = -O
+
+@@ -34,9 +34,11 @@
+
+ $(BINPATH)/kcc: kcc.c
+ $(MAKE) kcc
++ mkdir -p $(BINPATH)
+ $(INSTALL) -s kcc $(BINPATH)
+
+ $(MANPATH)/$(JMANDIR)/man1/kcc.1: kcc.jman
++ mkdir -p $@
+ $(INSTALL) -m 644 kcc.jman $@
+
+ clean:
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
new file mode 100644
index 000000000000..14806663851d
--- /dev/null
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#
+
+KEYWORDS="~x86"
+S="${WORKDIR}/${PN}"
+DESCRIPTION="A Kanji code converter"
+SRC_URI="ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/distfiles/${PN}.tar.gz"
+HOMEPAGE="" #There doesn't seem to be a home page for this package!
+LICENSE="GPL2"
+
+DEPEND="virtual/glibc"
+
+SLOT=0
+
+src_unpack() {
+
+ # unpack the archive
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}/gentoo.diff || die
+}
+
+src_compile() {
+ make
+}
+
+src_install () {
+
+ # install libs, executables, dictionaries
+ make DESTDIR=${D} install || die "installation failed"
+
+ # install docs
+ dodoc README
+}