summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-02-05 11:42:55 +0000
committerBen de Groot <yngwin@gentoo.org>2013-02-05 11:42:55 +0000
commit119805c29b8b2a25e3aa03c1e1c2c83b39759af8 (patch)
tree242959649f2661fae3aef165ad1fa2ff58c36b7a /app-i18n/ibus-table
parentversion bump (diff)
downloadgentoo-2-119805c29b8b2a25e3aa03c1e1c2c83b39759af8.tar.gz
gentoo-2-119805c29b8b2a25e3aa03c1e1c2c83b39759af8.tar.bz2
gentoo-2-119805c29b8b2a25e3aa03c1e1c2c83b39759af8.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/ChangeLog10
-rw-r--r--app-i18n/ibus-table/ibus-table-1.5.0.ebuild56
2 files changed, 63 insertions, 3 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 1a64f57a0191..ca87a604a485 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-table
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.27 2012/06/14 12:37:38 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.28 2013/02/05 11:42:55 yngwin Exp $
+
+*ibus-table-1.5.0 (05 Feb 2013)
+
+ 05 Feb 2013; Ben de Groot <yngwin@gentoo.org> +ibus-table-1.5.0.ebuild:
+ version bump
*ibus-table-1.3.9.20110827-r1 (14 Jun 2012)
@@ -159,4 +164,3 @@
10 Sep 2008; MATSUU Takuto <matsuu@gentoo.org> +metadata.xml,
+ibus-table-0.1.1.20080901.ebuild:
Initial import, bug #236483.
-
diff --git a/app-i18n/ibus-table/ibus-table-1.5.0.ebuild b/app-i18n/ibus-table/ibus-table-1.5.0.ebuild
new file mode 100644
index 000000000000..83033b31223c
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.5.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.5.0.ebuild,v 1.1 2013/02/05 11:42:55 yngwin Exp $
+
+EAPI=5
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="sqlite"
+inherit eutils python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch ${FILESDIR}/${P}-pycompile.patch
+
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ python_convert_shebangs 2 engine/tabcreatedb.py || die
+ sed -i -e "s/python/python2/" \
+ engine/ibus-table-createdb.in engine/ibus-engine-table.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls) PYTHON="${EPREFIX}"/usr/bin/python2
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}