summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-28 01:13:18 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-28 01:13:18 +0000
commitfdee1cabb4f4512c2c372561eac7578909b3941a (patch)
tree29eab3aa77bf47335df6b73dc9f1b92e92b05b37 /app-forensics
parentRemove old (diff)
downloadgentoo-2-fdee1cabb4f4512c2c372561eac7578909b3941a.tar.gz
gentoo-2-fdee1cabb4f4512c2c372561eac7578909b3941a.tar.bz2
gentoo-2-fdee1cabb4f4512c2c372561eac7578909b3941a.zip
Update to EAPI 4 and add static-libs use flag.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/ChangeLog5
-rw-r--r--app-forensics/libewf/libewf-20100226-r1.ebuild25
2 files changed, 13 insertions, 17 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index 01d0847eecb8..f3d991ac335c 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.12 2011/08/16 13:17:53 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.13 2011/09/28 01:13:18 radhermit Exp $
+
+ 28 Sep 2011; Tim Harder <radhermit@gentoo.org> libewf-20100226-r1.ebuild:
+ Update to EAPI 4 and add static-libs use flag.
*libewf-20100226-r1 (16 Aug 2011)
diff --git a/app-forensics/libewf/libewf-20100226-r1.ebuild b/app-forensics/libewf/libewf-20100226-r1.ebuild
index 7959d86215a4..9a16236a6c00 100644
--- a/app-forensics/libewf/libewf-20100226-r1.ebuild
+++ b/app-forensics/libewf/libewf-20100226-r1.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20100226-r1.ebuild,v 1.1 2011/08/16 13:17:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20100226-r1.ebuild,v 1.2 2011/09/28 01:13:18 radhermit Exp $
-EAPI="2"
-
-inherit eutils autotools
+EAPI="4"
DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
HOMEPAGE="http://libewf.sourceforge.net"
@@ -15,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
# upstream bug #2597171, pyewf has implicit declarations
#IUSE="debug python rawio unicode"
-IUSE="ewf2 debug rawio unicode"
+IUSE="debug ewf2 rawio static-libs unicode"
DEPEND="
sys-libs/e2fsprogs-libs
@@ -23,24 +21,19 @@ DEPEND="
dev-libs/openssl"
RDEPEND="${DEPEND}"
-src_prepare() {
- eautoreconf
-}
-
src_configure() {
econf \
- $(use_enable unicode wide-character-type) \
- $(use_enable rawio low-level-functions) \
- $(use_enable debug verbose-output) \
$(use_enable debug debug-output) \
- $(use_enable ewf2 v2-api) || die "Failed to configure"
-}
-src_compile() {
- emake || die "Failed to build"
+ $(use_enable debug verbose-output) \
+ $(use_enable ewf2 v2-api) \
+ $(use_enable rawio low-level-functions) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode wide-character-type)
}
src_install() {
emake install DESTDIR="${D}"
dodoc AUTHORS ChangeLog NEWS README documents/*.txt
doman manuals/*.1 manuals/*.3
+ find "${D}" -name '*.la' -exec rm -f {} +
}