summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-08 16:36:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-08 16:36:49 +0000
commit7b84b43106bde9c08d2230651fbfedb63dc12e7e (patch)
tree7cb5fee4f5ca1300bf9d62493a0e165637ef7f49 /app-forensics
parentBump to 3.321 (diff)
downloadgentoo-2-7b84b43106bde9c08d2230651fbfedb63dc12e7e.tar.gz
gentoo-2-7b84b43106bde9c08d2230651fbfedb63dc12e7e.tar.bz2
gentoo-2-7b84b43106bde9c08d2230651fbfedb63dc12e7e.zip
Bump to 3.0.1
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/ChangeLog7
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.0.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index c1b9580e18e2..639c906fcf2e 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/sleuthkit
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.39 2009/03/06 00:01:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.40 2009/03/08 16:36:49 patrick Exp $
+
+*sleuthkit-3.0.1 (08 Mar 2009)
+
+ 08 Mar 2009; Patrick Lauer <patrick@gentoo.org> +sleuthkit-3.0.1.ebuild:
+ Bump to 3.0.1
06 Mar 2009; Jeroen Roovers <jer@gentoo.org> sleuthkit-3.0.0.ebuild,
sleuthkit-3.0.0-r1.ebuild:
diff --git a/app-forensics/sleuthkit/sleuthkit-3.0.1.ebuild b/app-forensics/sleuthkit/sleuthkit-3.0.1.ebuild
new file mode 100644
index 000000000000..9e89dccdeb93
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-3.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.0.1.ebuild,v 1.1 2009/03/08 16:36:49 patrick Exp $
+
+inherit eutils flag-o-matic autotools
+
+SLOT=0
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+
+DEPEND="ewf? ( app-forensics/libewf )
+ aff? ( app-forensics/afflib )"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+IUSE="aff ewf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # AC_FUNC_REALLOC in configure.ac that hasn't been propagated
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc docs/*.txt README.txt CHANGES.txt TODO.txt
+}