summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-09-18 05:37:56 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-09-18 05:37:56 +0000
commitd9d134fcdc122fcce6d0a200222025416dff6882 (patch)
tree6122e41dfb5a52e5ba7396f8f0a92d56c614929c /app-emulation
parentRemoved old versions (diff)
downloadgentoo-2-d9d134fcdc122fcce6d0a200222025416dff6882.tar.gz
gentoo-2-d9d134fcdc122fcce6d0a200222025416dff6882.tar.bz2
gentoo-2-d9d134fcdc122fcce6d0a200222025416dff6882.zip
Removed old versions
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtualbox-guest-additions/ChangeLog7
-rw-r--r--app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.12.ebuild199
-rw-r--r--app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.18.ebuild199
3 files changed, 6 insertions, 399 deletions
diff --git a/app-emulation/virtualbox-guest-additions/ChangeLog b/app-emulation/virtualbox-guest-additions/ChangeLog
index ac1fb38ae6db..943863231dc0 100644
--- a/app-emulation/virtualbox-guest-additions/ChangeLog
+++ b/app-emulation/virtualbox-guest-additions/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virtualbox-guest-additions
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-guest-additions/ChangeLog,v 1.104 2012/09/17 20:10:44 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-guest-additions/ChangeLog,v 1.105 2012/09/18 05:37:56 polynomial-c Exp $
+
+ 18 Sep 2012; Lars Wendler <polynomial-c@gentoo.org>
+ -virtualbox-guest-additions-4.1.12.ebuild,
+ -virtualbox-guest-additions-4.1.18.ebuild:
+ Removed old versions.
17 Sep 2012; Andreas Schuerch <nativemad@gentoo.org>
virtualbox-guest-additions-4.1.22.ebuild:
diff --git a/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.12.ebuild b/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.12.ebuild
deleted file mode 100644
index 060075b924b7..000000000000
--- a/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.12.ebuild
+++ /dev/null
@@ -1,199 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.12.ebuild,v 1.4 2012/06/01 00:03:28 zmedico Exp $
-
-EAPI=2
-
-inherit eutils linux-mod user
-
-MY_P=VirtualBox-${PV}
-DESCRIPTION="VirtualBox kernel modules and user-space tools for Linux guests"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="X"
-
-RDEPEND="X? ( ~x11-drivers/xf86-video-virtualbox-${PV}
- x11-apps/xrandr
- x11-apps/xrefresh
- x11-libs/libXmu
- x11-libs/libX11
- x11-libs/libXt
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libSM
- x11-libs/libICE )
- !!x11-drivers/xf86-input-virtualbox"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.999
- >=dev-lang/yasm-0.6.2
- sys-devel/bin86
- sys-devel/dev86
- sys-libs/pam
- sys-power/iasl
- X? ( x11-proto/renderproto )
- !X? ( x11-proto/xproto )"
-
-BUILD_TARGETS="all"
-BUILD_TARGET_ARCH="${ARCH}"
-MODULE_NAMES="vboxguest(misc:${WORKDIR}/vboxguest:${WORKDIR}/vboxguest)
- vboxsf(misc:${WORKDIR}/vboxsf:${WORKDIR}/vboxsf)"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
- enewgroup vboxguest
- enewuser vboxguest -1 /bin/sh /var/run/vboxguest vboxguest
-}
-
-src_unpack() {
- unpack ${A}
-
- # Create and unpack a tarball with the sources of the Linux guest
- # kernel modules, to include all the needed files
- "${S}"/src/VBox/Additions/linux/export_modules "${WORKDIR}/vbox-kmod.tar.gz"
- unpack ./vbox-kmod.tar.gz
-
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- cd "${S}"
- rm -rf kBuild/bin tools
-}
-
-src_prepare() {
- # PaX fixes (see bug #298988)
- pushd "${WORKDIR}" &>/dev/null || die
- epatch "${FILESDIR}"/vboxguest-4.1.0-log-use-c99.patch
- popd &>/dev/null || die
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-3-localconfig" LocalConfig.kmk
-
- # stupid new header references...
- for vboxheader in {product,revision}-generated.h ; do
- for mdir in vbox{guest,sf} ; do
- ln -sf "${S}"/out/linux.${ARCH}/release/${vboxheader} \
- "${WORKDIR}/${mdir}/${vboxheader}"
- done
- done
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
-}
-
-src_compile() {
- source ./env.sh
-
- for each in /src/VBox/{Runtime,Additions/common} \
- /src/VBox/Additions/linux/{sharedfolders,daemon} ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk VBoxControl failed"
- done
-
- if use X; then
- cd "${S}"/src/VBox/Additions/x11/VBoxClient
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk VBoxClient failed"
- fi
-
- # Now creating the kernel modules. We must do this _after_
- # we compiled the user-space tools as we need two of the
- # automatically generated header files. (>=3.2.0)
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
-
- cd "${S}"/out/linux.${ARCH}/release/bin/additions
-
- insinto /sbin
- newins mount.vboxsf mount.vboxsf
- fperms 4755 /sbin/mount.vboxsf
-
- newinitd "${FILESDIR}"/${PN}-7.initd ${PN}
-
- insinto /usr/sbin/
- newins VBoxService vboxguest-service
- fperms 0755 /usr/sbin/vboxguest-service
-
- insinto /usr/bin
- doins VBoxControl
- fperms 0755 /usr/bin/VBoxControl
-
- # VBoxClient user service and xrandr wrapper
- if use X; then
- doins VBoxClient
- fperms 0755 /usr/bin/VBoxClient
-
- cd "${S}"/src/VBox/Additions/x11/Installer
- newins 98vboxadd-xclient VBoxClient-all
- fperms 0755 /usr/bin/VBoxClient-all
- fi
-
- # udev rule for vboxdrv
- dodir /lib/udev/rules.d
- echo 'KERNEL=="vboxguest", OWNER="vboxguest", GROUP="vboxguest", MODE="0660"' \
- >> "${D}/lib/udev/rules.d/60-virtualbox-guest-additions.rules" \
- || die
- echo 'KERNEL=="vboxuser", OWNER="vboxguest", GROUP="vboxguest", MODE="0660"' \
- >> "${D}/lib/udev/rules.d/60-virtualbox-guest-additions.rules" \
- || die
-
- # VBoxClient autostart file
- insinto /etc/xdg/autostart
- doins "${FILESDIR}"/vboxclient.desktop
-
- # sample xorg.conf
- insinto /usr/share/doc/${PF}
- doins "${FILESDIR}"/xorg.conf.vbox
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- if ! use X ; then
- elog "use flag X is off, enable it to install the"
- elog "X Window System input and video drivers"
- fi
- elog ""
- elog "Please add users to the \"vboxguest\" group so they can"
- elog "benefit from seamless mode, auto-resize and clipboard."
- elog ""
- elog "Please add:"
- elog "/etc/init.d/${PN}"
- elog "to the default runlevel in order to start"
- elog "needed services."
- elog "To use the VirtualBox X drivers, use the following"
- elog "file as your /etc/X11/xorg.conf:"
- elog " /usr/share/doc/${PF}/xorg.conf.xorg"
- elog ""
- elog "Also make sure you use the Mesa library for OpenGL:"
- elog " eselect opengl set xorg-x11"
- elog ""
- elog "An autostart .desktop file has been installed to start"
- elog "VBoxClient in desktop sessions."
- elog ""
- elog "You can mount shared folders with:"
- elog " mount -t vboxsf <shared_folder_name> <mount_point>"
- elog ""
- elog "Warning:"
- elog "this ebuild is only needed if you are running gentoo"
- elog "inside a VirtualBox Virtual Machine, you don't need"
- elog "it to run VirtualBox itself."
- elog ""
-}
diff --git a/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.18.ebuild b/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.18.ebuild
deleted file mode 100644
index d505af14bd9e..000000000000
--- a/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.18.ebuild
+++ /dev/null
@@ -1,199 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-guest-additions/virtualbox-guest-additions-4.1.18.ebuild,v 1.2 2012/08/07 21:14:52 hwoarang Exp $
-
-EAPI=2
-
-inherit eutils linux-mod user
-
-MY_P=VirtualBox-${PV}
-DESCRIPTION="VirtualBox kernel modules and user-space tools for Linux guests"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="X"
-
-RDEPEND="X? ( ~x11-drivers/xf86-video-virtualbox-${PV}
- x11-apps/xrandr
- x11-apps/xrefresh
- x11-libs/libXmu
- x11-libs/libX11
- x11-libs/libXt
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libSM
- x11-libs/libICE )
- !!x11-drivers/xf86-input-virtualbox"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.999
- >=dev-lang/yasm-0.6.2
- sys-devel/bin86
- sys-devel/dev86
- sys-libs/pam
- sys-power/iasl
- X? ( x11-proto/renderproto )
- !X? ( x11-proto/xproto )"
-
-BUILD_TARGETS="all"
-BUILD_TARGET_ARCH="${ARCH}"
-MODULE_NAMES="vboxguest(misc:${WORKDIR}/vboxguest:${WORKDIR}/vboxguest)
- vboxsf(misc:${WORKDIR}/vboxsf:${WORKDIR}/vboxsf)"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
- enewgroup vboxguest
- enewuser vboxguest -1 /bin/sh /var/run/vboxguest vboxguest
-}
-
-src_unpack() {
- unpack ${A}
-
- # Create and unpack a tarball with the sources of the Linux guest
- # kernel modules, to include all the needed files
- "${S}"/src/VBox/Additions/linux/export_modules "${WORKDIR}/vbox-kmod.tar.gz"
- unpack ./vbox-kmod.tar.gz
-
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- cd "${S}"
- rm -rf kBuild/bin tools
-}
-
-src_prepare() {
- # PaX fixes (see bug #298988)
- pushd "${WORKDIR}" &>/dev/null || die
- epatch "${FILESDIR}"/vboxguest-4.1.0-log-use-c99.patch
- popd &>/dev/null || die
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-3-localconfig" LocalConfig.kmk
-
- # stupid new header references...
- for vboxheader in {product,revision}-generated.h ; do
- for mdir in vbox{guest,sf} ; do
- ln -sf "${S}"/out/linux.${ARCH}/release/${vboxheader} \
- "${WORKDIR}/${mdir}/${vboxheader}"
- done
- done
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
-}
-
-src_compile() {
- source ./env.sh
-
- for each in /src/VBox/{Runtime,Additions/common} \
- /src/VBox/Additions/linux/{sharedfolders,daemon} ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk VBoxControl failed"
- done
-
- if use X; then
- cd "${S}"/src/VBox/Additions/x11/VBoxClient
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk VBoxClient failed"
- fi
-
- # Now creating the kernel modules. We must do this _after_
- # we compiled the user-space tools as we need two of the
- # automatically generated header files. (>=3.2.0)
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
-
- cd "${S}"/out/linux.${ARCH}/release/bin/additions
-
- insinto /sbin
- newins mount.vboxsf mount.vboxsf
- fperms 4755 /sbin/mount.vboxsf
-
- newinitd "${FILESDIR}"/${PN}-7.initd ${PN}
-
- insinto /usr/sbin/
- newins VBoxService vboxguest-service
- fperms 0755 /usr/sbin/vboxguest-service
-
- insinto /usr/bin
- doins VBoxControl
- fperms 0755 /usr/bin/VBoxControl
-
- # VBoxClient user service and xrandr wrapper
- if use X; then
- doins VBoxClient
- fperms 0755 /usr/bin/VBoxClient
-
- cd "${S}"/src/VBox/Additions/x11/Installer
- newins 98vboxadd-xclient VBoxClient-all
- fperms 0755 /usr/bin/VBoxClient-all
- fi
-
- # udev rule for vboxdrv
- dodir /lib/udev/rules.d
- echo 'KERNEL=="vboxguest", OWNER="vboxguest", GROUP="vboxguest", MODE="0660"' \
- >> "${D}/lib/udev/rules.d/60-virtualbox-guest-additions.rules" \
- || die
- echo 'KERNEL=="vboxuser", OWNER="vboxguest", GROUP="vboxguest", MODE="0660"' \
- >> "${D}/lib/udev/rules.d/60-virtualbox-guest-additions.rules" \
- || die
-
- # VBoxClient autostart file
- insinto /etc/xdg/autostart
- doins "${FILESDIR}"/vboxclient.desktop
-
- # sample xorg.conf
- insinto /usr/share/doc/${PF}
- doins "${FILESDIR}"/xorg.conf.vbox
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- if ! use X ; then
- elog "use flag X is off, enable it to install the"
- elog "X Window System input and video drivers"
- fi
- elog ""
- elog "Please add users to the \"vboxguest\" group so they can"
- elog "benefit from seamless mode, auto-resize and clipboard."
- elog ""
- elog "Please add:"
- elog "/etc/init.d/${PN}"
- elog "to the default runlevel in order to start"
- elog "needed services."
- elog "To use the VirtualBox X drivers, use the following"
- elog "file as your /etc/X11/xorg.conf:"
- elog " /usr/share/doc/${PF}/xorg.conf.xorg"
- elog ""
- elog "Also make sure you use the Mesa library for OpenGL:"
- elog " eselect opengl set xorg-x11"
- elog ""
- elog "An autostart .desktop file has been installed to start"
- elog "VBoxClient in desktop sessions."
- elog ""
- elog "You can mount shared folders with:"
- elog " mount -t vboxsf <shared_folder_name> <mount_point>"
- elog ""
- elog "Warning:"
- elog "this ebuild is only needed if you are running gentoo"
- elog "inside a VirtualBox Virtual Machine, you don't need"
- elog "it to run VirtualBox itself."
- elog ""
-}