summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-10-23 23:21:09 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-10-23 23:21:09 +0000
commitd8a99ddd0ad5e1b5645101fed4a9b471b8971037 (patch)
treee561fb14f962b0b33d920c45f160b1ce0d31a21e /app-emulation
parentcompletely revamp the ebuild to be updated with new features present in 0.7.2... (diff)
downloadgentoo-2-d8a99ddd0ad5e1b5645101fed4a9b471b8971037.tar.gz
gentoo-2-d8a99ddd0ad5e1b5645101fed4a9b471b8971037.tar.bz2
gentoo-2-d8a99ddd0ad5e1b5645101fed4a9b471b8971037.zip
remove incomplete ebuilds for 0.7.x
(Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog6
-rw-r--r--app-emulation/libvirt/libvirt-0.7.0.ebuild102
-rw-r--r--app-emulation/libvirt/libvirt-0.7.1.ebuild102
3 files changed, 5 insertions, 205 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index a62ad909af2d..a14f8d618790 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.35 2009/10/23 23:19:06 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.36 2009/10/23 23:21:09 cardoe Exp $
+
+ 23 Oct 2009; Doug Goldstein <cardoe@gentoo.org> -libvirt-0.7.0.ebuild,
+ -libvirt-0.7.1.ebuild:
+ remove incomplete ebuilds for 0.7.x
23 Oct 2009; Doug Goldstein <cardoe@gentoo.org> libvirt-0.7.2.ebuild:
completely revamp the ebuild to be updated with new features present in
diff --git a/app-emulation/libvirt/libvirt-0.7.0.ebuild b/app-emulation/libvirt/libvirt-0.7.0.ebuild
deleted file mode 100644
index 29ffc060dd23..000000000000
--- a/app-emulation/libvirt/libvirt-0.7.0.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.7.0.ebuild,v 1.1 2009/10/21 16:04:51 cardoe Exp $
-
-EAPI="2"
-
-inherit eutils autotools confutils
-
-DESCRIPTION="C toolkit to manipulate virtual machines"
-HOMEPAGE="http://www.libvirt.org/"
-SRC_URI="http://libvirt.org/sources/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="avahi iscsi hal kvm lvm +lxc +network nls numa openvz policykit \
- parted qemu sasl selinux uml virtualbox xen"
-# devicekit isn't in portage
-
-RDEPEND="sys-libs/readline
- sys-libs/ncurses
- >=dev-libs/libxml2-2.5
- >=net-libs/gnutls-1.0.25
- dev-lang/python
- sys-fs/sysfsutils
- >=net-analyzer/netcat6-1.0-r2
- avahi? ( >=net-dns/avahi-0.6 )
- hal? ( >=sys-apps/hal-0.5.9 )
- iscsi? ( sys-block/open-iscsi )
- kvm? ( app-emulation/kvm )
- lvm? ( sys-fs/lvm2 )
- network? ( net-misc/bridge-utils net-dns/dnsmasq net-firewall/iptables )
- numa? ( sys-process/numactl )
- openvz? ( sys-kernel/openvz-sources )
- parted? ( >=sys-apps/parted-1.8 )
- policykit? ( >=sys-auth/policykit-0.6 )
- qemu? ( >=app-emulation/qemu-0.10.0 )
- sasl? ( dev-libs/cyrus-sasl )
- selinux? ( sys-libs/libselinux )
- virtualbox? ( || ( >=app-emulation/virtualbox-ose-2.2.0 >=app-emulation/virtualbox-bin-2.2.0 ) )
- xen? ( app-emulation/xen-tools app-emulation/xen )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-pkg_setup() {
- confutils_require_any lxc kvm openvz qemu uml virtualbox xen
-}
-
-src_configure() {
- local my_conf=""
- if use qemu || use kvm ; then
- my_conf="--with-qemu"
- else
- my_conf="--without-qemu"
- fi
-
- econf \
- $(use_with iscsi storage-iscsi) \
- $(use_with lvm storage-lvm) \
- $(use_with parted storage-disk) \
- $(use_with lxc) \
- $(use_with openvz) \
- $(use_with uml) \
- $(use_with virtualbox vbox) \
- $(use_with xen) \
- $(use_with xen xen-inotify) \
- $(use_with avahi) \
- $(use_with hal) \
- $(use_with sasl) \
- $(use_with network) \
- $(use_with policykit polkit) \
- $(use_with selinux) \
- $(use_enable nls) \
- $(use_with numa numactl) \
- ${my_conf} \
- --without-devkit \
- --with-remote \
- --disable-iptables-lokkit \
- --localstatedir=/var \
- --with-remote-pid-file=/var/run/libvirtd.pid
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake instal lfailed"
- mv "${D}"/usr/share/doc/{${PN}-python*,${P}/python}
-
- newinitd "${FILESDIR}/libvirtd.init" libvirtd
- newconfd "${FILESDIR}/libvirtd.confd" libvirtd
-
- keepdir /var/lib/libvirt/images
-}
-
-pkg_postinst() {
- elog "To allow normal users to connect to libvirtd you must change the"
- elog " unix sock group and/or perms in /etc/libvirt/libvirtd.conf"
- elog
- ewarn "If you have a DNS server setup on your machine, you will have"
- ewarn "to configure /etc/dnsmasq.conf to enable the following settings: "
- ewarn " bind-interfaces"
- ewarn " interface or except-interface"
- elog
- ewarn "Otherwise you might have issues with your existing DNS server."
-}
diff --git a/app-emulation/libvirt/libvirt-0.7.1.ebuild b/app-emulation/libvirt/libvirt-0.7.1.ebuild
deleted file mode 100644
index 8c1f98a3d3a0..000000000000
--- a/app-emulation/libvirt/libvirt-0.7.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.7.1.ebuild,v 1.1 2009/10/21 16:04:51 cardoe Exp $
-
-EAPI="2"
-
-inherit eutils autotools confutils
-
-DESCRIPTION="C toolkit to manipulate virtual machines"
-HOMEPAGE="http://www.libvirt.org/"
-SRC_URI="http://libvirt.org/sources/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="avahi iscsi hal kvm lvm +lxc +network nls numa openvz policykit \
- parted qemu sasl selinux uml virtualbox xen"
-# devicekit isn't in portage
-
-RDEPEND="sys-libs/readline
- sys-libs/ncurses
- >=dev-libs/libxml2-2.5
- >=net-libs/gnutls-1.0.25
- dev-lang/python
- sys-fs/sysfsutils
- >=net-analyzer/netcat6-1.0-r2
- avahi? ( >=net-dns/avahi-0.6 )
- hal? ( >=sys-apps/hal-0.5.9 )
- iscsi? ( sys-block/open-iscsi )
- kvm? ( app-emulation/kvm )
- lvm? ( sys-fs/lvm2 )
- network? ( net-misc/bridge-utils net-dns/dnsmasq net-firewall/iptables )
- numa? ( sys-process/numactl )
- openvz? ( sys-kernel/openvz-sources )
- parted? ( >=sys-apps/parted-1.8 )
- policykit? ( >=sys-auth/policykit-0.6 )
- qemu? ( >=app-emulation/qemu-0.10.0 )
- sasl? ( dev-libs/cyrus-sasl )
- selinux? ( sys-libs/libselinux )
- virtualbox? ( || ( >=app-emulation/virtualbox-ose-2.2.0 >=app-emulation/virtualbox-bin-2.2.0 ) )
- xen? ( app-emulation/xen-tools app-emulation/xen )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-pkg_setup() {
- confutils_require_any lxc kvm openvz qemu uml virtualbox xen
-}
-
-src_configure() {
- local my_conf=""
- if use qemu || use kvm ; then
- my_conf="--with-qemu"
- else
- my_conf="--without-qemu"
- fi
-
- econf \
- $(use_with iscsi storage-iscsi) \
- $(use_with lvm storage-lvm) \
- $(use_with parted storage-disk) \
- $(use_with lxc) \
- $(use_with openvz) \
- $(use_with uml) \
- $(use_with virtualbox vbox) \
- $(use_with xen) \
- $(use_with xen xen-inotify) \
- $(use_with avahi) \
- $(use_with hal) \
- $(use_with sasl) \
- $(use_with network) \
- $(use_with policykit polkit) \
- $(use_with selinux) \
- $(use_enable nls) \
- $(use_with numa numactl) \
- ${my_conf} \
- --without-devkit \
- --with-remote \
- --disable-iptables-lokkit \
- --localstatedir=/var \
- --with-remote-pid-file=/var/run/libvirtd.pid
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake instal lfailed"
- mv "${D}"/usr/share/doc/{${PN}-python*,${P}/python}
-
- newinitd "${FILESDIR}/libvirtd.init" libvirtd
- newconfd "${FILESDIR}/libvirtd.confd" libvirtd
-
- keepdir /var/lib/libvirt/images
-}
-
-pkg_postinst() {
- elog "To allow normal users to connect to libvirtd you must change the"
- elog " unix sock group and/or perms in /etc/libvirt/libvirtd.conf"
- elog
- ewarn "If you have a DNS server setup on your machine, you will have"
- ewarn "to configure /etc/dnsmasq.conf to enable the following settings: "
- ewarn " bind-interfaces"
- ewarn " interface or except-interface"
- elog
- ewarn "Otherwise you might have issues with your existing DNS server."
-}