summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-02-16 12:21:12 +0000
committerPacho Ramos <pacho@gentoo.org>2013-02-16 12:21:12 +0000
commitc3fbfa2059a4825a65f60500685331aecfa50660 (patch)
tree5ced7d0ef9b39be346bffbedbf810cb11a205c99 /app-emulation
parentCleanup due bug #96436 (diff)
downloadgentoo-2-c3fbfa2059a4825a65f60500685331aecfa50660.tar.gz
gentoo-2-c3fbfa2059a4825a65f60500685331aecfa50660.tar.bz2
gentoo-2-c3fbfa2059a4825a65f60500685331aecfa50660.zip
Cleanup due bug #96436
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/e-uae/ChangeLog8
-rw-r--r--app-emulation/e-uae/e-uae-0.8.29_rc4-r1.ebuild141
-rw-r--r--app-emulation/e-uae/metadata.xml3
3 files changed, 7 insertions, 145 deletions
diff --git a/app-emulation/e-uae/ChangeLog b/app-emulation/e-uae/ChangeLog
index 7fde95c5a93c..5ae688542f4a 100644
--- a/app-emulation/e-uae/ChangeLog
+++ b/app-emulation/e-uae/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/e-uae
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.44 2012/12/11 18:21:18 grobian Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.45 2013/02/16 12:21:12 pacho Exp $
+
+ 16 Feb 2013; Pacho Ramos <pacho@gentoo.org> -e-uae-0.8.29_rc4-r1.ebuild,
+ metadata.xml:
+ Cleanup due bug #96436
11 Dec 2012; Fabian Groffen <grobian@gentoo.org> e-uae-0.8.28-r3.ebuild:
Fix build issue, bug #425680
diff --git a/app-emulation/e-uae/e-uae-0.8.29_rc4-r1.ebuild b/app-emulation/e-uae/e-uae-0.8.29_rc4-r1.ebuild
deleted file mode 100644
index d4b64564bd79..000000000000
--- a/app-emulation/e-uae/e-uae-0.8.29_rc4-r1.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/e-uae-0.8.29_rc4-r1.ebuild,v 1.3 2011/03/27 10:22:51 nirbheek Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic pax-utils
-
-DESCRIPTION="The Ubiquitous Amiga Emulator with an emulation core largely based on WinUAE"
-HOMEPAGE="http://www.rcdrummond.net/uae/"
-# We support _rcX for WIPX versions and _preYYYYMMDD for CVS snapshots.
-if [[ "${PV%%_rc*}" = "${PV}" ]] ; then
- # _pre is used, cvs version
- my_ver=${PV%%_pre*}
- snap_ver=${PV##*_pre}
- S="${WORKDIR}"/${PN}-${my_ver}-${snap_ver}
- SRC_URI="http://www.rcdrummond.net/uae/test/${snap_ver}/${PN}-${my_ver}-${snap_ver}.tar.bz2"
-else
- my_ver=${PV%%_rc*}
- WIP_ver=${PV##*_rc}
- S="${WORKDIR}"/${PN}-${my_ver}-WIP${WIP_ver}
- SRC_URI="http://www.rcdrummond.net/uae/${PN}-${my_ver}-WIP${WIP_ver}/${PN}-${my_ver}-WIP${WIP_ver}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="X dga ncurses sdl gtk alsa oss sdl-sound capslib"
-
-# Note: opposed to ./configure --help zlib support required! Check
-# src/Makefile.am that includes zfile.c unconditionaly.
-RDEPEND="X? ( x11-libs/libXt
- x11-libs/libxkbfile
- x11-libs/libXext
- dga? ( x11-libs/libXxf86dga
- x11-libs/libXxf86vm )
- )
- !X? ( sdl? ( media-libs/libsdl )
- !sdl? ( sys-libs/ncurses ) )
- alsa? ( media-libs/alsa-lib )
- !alsa? ( sdl-sound? ( media-libs/sdl-sound ) )
- gtk? ( x11-libs/gtk+:2 )
- capslib? ( >=games-emulation/caps-20060612 )
- sys-libs/zlib
- virtual/cdrtools"
-
-DEPEND="$RDEPEND
- X? ( dga? ( x11-proto/xf86vidmodeproto
- x11-proto/xf86dgaproto ) )"
-
-pkg_setup() {
- # Sound setup.
- if use alsa; then
- elog "Choosing alsa as sound target to use."
- myconf="--with-alsa --without-sdl-sound"
- elif use sdl-sound ; then
- if ! use sdl ; then
- ewarn "sdl-sound is not enabled because sdl USE flag is disabled. Leaving"
- ewarn "sound on oss autodetection."
- myconf="--without-alsa --without-sdl-sound"
- ebeep
- else
- elog "Choosing sdl-sound as sound target to use."
- ewarn "E-UAE with the SDL audio back-end doesn't work correctly in Linux."
- ewarn "Better use alsa... You've been warned ;)"
- ebeep
- myconf="--without-alsa --with-sdl-sound"
- fi
- elif use oss ; then
- elog "Choosing oss as sound target to use."
- ewarn "oss will be autodetected. See output of configure."
- myconf="--without-alsa --without-sdl-sound"
- else
- ewarn "There is no alsa, sdl-sound or oss in USE. Sound target disabled!"
- myconf="--disable-audio"
- fi
-
- # VIDEO setup. X is autodetected (there is no --with-X option).
- if use X ; then
- elog "Using X11 for video output."
- ewarn "Fullscreen mode is not working in X11 currently. Use sdl."
- myconf="$myconf --without-curses --without-sdl-gfx"
- use dga && ewarn "To use dga you have to run e-uae as root."
- use dga && myconf="$myconf --enable-dga --enable-vidmode"
- elif use sdl ; then
- elog "Using sdl for video output."
- myconf="$myconf --with-sdl --with-sdl-gfx --without-curses"
- elif use ncurses; then
- elog "Using ncurses for video output."
- myconf="$myconf --with-curses --without-sdl-gfx"
- else
- ewarn "There is no X or sdl or ncurses in USE!"
- ewarn "Following upstream falling back on ncurses."
- myconf="$myconf --with-curses --without-sdl-gfx"
- ebeep
- fi
-
- use gtk && myconf="$myconf --enable-ui --enable-threads"
- use gtk || myconf="$myconf --disable-ui"
-
- myconf="$myconf $(use_with capslib caps)"
-
- myconf="$myconf --with-zlib"
-
- # And explicitly state defaults:
- myconf="$myconf --enable-aga"
- myconf="$myconf --enable-autoconfig --enable-scsi-device --enable-cdtv --enable-cd32"
- myconf="$myconf --enable-bsdsock"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix for high cpu use when compiled with --disable-audio
- use alsa || use sdl-sound || use oss || epatch "${FILESDIR}"/${P}-high-cpu-usage.patch
-}
-
-src_compile() {
- strip-flags
-
- econf ${myconf} \
- --with-libscg-includedir=/usr/include/scsilib \
- || die "./configure failed"
-
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # The emulator needs to be able to create executable heap
- # - doesn't need trampoline emulation though.
- pax-mark me "${D}/usr/bin/uae"
-
- # Rename it to e-uae
- mv "${D}/usr/bin/uae" "${D}/usr/bin/${PN}"
- mv "${D}/usr/bin/readdisk" "${D}/usr/bin/e-readdisk"
-
- dodoc docs/* README ChangeLog
-}
diff --git a/app-emulation/e-uae/metadata.xml b/app-emulation/e-uae/metadata.xml
index 9a84b87cdd3d..2314e7afa121 100644
--- a/app-emulation/e-uae/metadata.xml
+++ b/app-emulation/e-uae/metadata.xml
@@ -2,8 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>pva@gentoo.org</email>
- <name>Peter Volkov</name>
+ <email>maintainer-needed@gentoo.org</email>
</maintainer>
<longdescription lang="en">
E-UAE is a fork of UAE which intends to merge all the new features of