summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2009-06-30 12:27:06 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2009-06-30 12:27:06 +0000
commitb7256eb513dbe77882875b5e38d081a4d925639a (patch)
tree8d6d3b5128929645fb4455df818bcf1d90858215 /app-emulation
parentVersion bump, prepare ebuild for plugins support (symlink to nsbrowser ones) (diff)
downloadgentoo-2-b7256eb513dbe77882875b5e38d081a4d925639a.tar.gz
gentoo-2-b7256eb513dbe77882875b5e38d081a4d925639a.tar.bz2
gentoo-2-b7256eb513dbe77882875b5e38d081a4d925639a.zip
Version bump. Bug 273887 - missing dev-libs/glib dependency.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog9
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild3
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild129
3 files changed, 139 insertions, 2 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index d9554c0b5bb4..19e007c6aade 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.19 2009/06/08 13:41:57 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.20 2009/06/30 12:27:06 vadimk Exp $
+
+*open-vm-tools-0.0.20090618.172495 (30 Jun 2009)
+
+ 30 Jun 2009; Vadim Kuznetsov vadimk@gentoo.org
+ open-vm-tools-0.0.20090522.167859.ebuild,
+ +open-vm-tools-0.0.20090618.172495.ebuild:
+ Version bump. Bug 273887 - missing dev-libs/glib dependency.
08 Jun 2009; Vadim Kuznetsov vadimk@gentoo.org
open-vm-tools-0.0.20090522.167859.ebuild:
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild
index 235735c67a8e..1cc7b84315e1 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild,v 1.2 2009/06/08 13:41:57 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild,v 1.3 2009/06/30 12:27:06 vadimk Exp $
EAPI="2"
@@ -41,6 +41,7 @@ DEPEND="
!app-emulation/vmware-esx-tools
sys-process/procps
dev-libs/libdnet
+ >=dev-libs/glib-2
icu? ( dev-libs/icu )
"
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild
new file mode 100644
index 000000000000..fbe61a77663c
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild,v 1.1 2009/06/30 12:27:06 vadimk Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod pam versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${PN}-${MY_PV}"
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X xinerama icu unity"
+DEPEND="
+ !app-emulation/vmware-workstation-tools
+ !app-emulation/vmware-server-tools
+ !app-emulation/vmware-esx-tools
+ virtual/linux-sources
+ sys-apps/ethtool
+ X? (
+ x11-libs/libX11
+ x11-libs/gtk+
+ dev-cpp/gtkmm
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+ xinerama? (
+ x11-libs/libXinerama
+ )
+ sys-process/procps
+ dev-libs/libdnet
+ >=dev-libs/glib-2
+ icu? ( dev-libs/icu )
+ "
+
+RDEPEND="${DEPEND/virtual\/linux\-sources/}
+ virtual/pam
+ X? (
+ x11-base/xorg-server
+ x11-drivers/xf86-video-vmware
+ x11-drivers/xf86-input-vmmouse
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+ "
+
+VMWARE_MOD_DIR="modules/linux"
+VMWARE_MODULE_LIST="pvscsi vmblock vmci vmhgfs vmsync vmmemctl vmxnet vmxnet3 vsock"
+
+pkg_setup() {
+ use unity && ! use xinerama && \
+ die 'The Unity USE flag requires USE="xinerama" as well'
+
+ linux-mod_pkg_setup
+ MODULE_NAMES=""
+ BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR} OVT_SOURCE_DIR=${S}"
+
+ for mod in ${VMWARE_MODULE_LIST};
+ do
+ if [ "${mod}" == "vmxnet" -o "${mod}" == "vmxnet3" ];
+ then
+ MODTARGET="net"
+ else
+ MODTARGET="openvmtools"
+ fi
+ MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
+ done
+
+ enewgroup vmware
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/default-scripts.patch"
+ sed -e 's:VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)\\":VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)/plugins\\":g' -i services/vmtoolsd/Makefile.in
+}
+
+src_configure() {
+ econf \
+ --without-kernel-modules \
+ $(use_with icu) \
+ $(use_with X x) \
+ $(use_with X gtkmm) \
+ $(use_enable unity) \
+ $(use_enable xinerama multimon)
+}
+
+src_compile() {
+ linux-mod_src_compile
+
+ emake || die
+}
+
+src_install() {
+ linux-mod_src_install
+
+ emake DESTDIR="${D}" install || die "Failed to install"
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
+ newconfd "${FILESDIR}/open-vm.confd" vmware-tools
+
+ if use X;
+ then
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, you need to do this:"
+ elog " Add 'vmware-tools' to your default runlevel"
+ elog " Add the users which should have access to this function"
+ elog " to the group 'vmware'"
+ fi
+}