summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-08-12 12:33:55 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-08-12 12:33:55 +0000
commit7a89c745074aab4404b1dd105139497aaa36e672 (patch)
treeea6d8f9031f7a0b63633168925df4000af4a139a /app-emulation
parentStable ppc ppc64, addresses CVE-2013-2174, bug #474354 (diff)
downloadgentoo-2-7a89c745074aab4404b1dd105139497aaa36e672.tar.gz
gentoo-2-7a89c745074aab4404b1dd105139497aaa36e672.tar.bz2
gentoo-2-7a89c745074aab4404b1dd105139497aaa36e672.zip
Update SRC_URI links, apply patchset only in non-live ebuilds
(Portage version: 2.2.0_alpha193/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-user/ChangeLog5
-rw-r--r--app-emulation/qemu-user/qemu-user-9999.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index b786f4cf1dfc..f2185df69218 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.55 2013/08/12 12:10:58 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.56 2013/08/12 12:33:55 pinkbyte Exp $
+
+ 12 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> qemu-user-9999.ebuild:
+ Update SRC_URI links, apply patchset only in non-live ebuilds
12 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> qemu-user-9999.ebuild:
Remove unneeded epatch call, add support for epatch_user, wrt bug #428716.
diff --git a/app-emulation/qemu-user/qemu-user-9999.ebuild b/app-emulation/qemu-user/qemu-user-9999.ebuild
index 752a07486605..b59423b97877 100644
--- a/app-emulation/qemu-user/qemu-user-9999.ebuild
+++ b/app-emulation/qemu-user/qemu-user-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-9999.ebuild,v 1.6 2013/08/12 12:10:58 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-9999.ebuild,v 1.7 2013/08/12 12:33:55 pinkbyte Exp $
EAPI=4
@@ -15,8 +15,8 @@ inherit eutils base flag-o-matic pax-utils toolchain-funcs ${GIT_ECLASS}
MY_P=${P/-user/}
if [[ ${PV} != *9999 ]]; then
-SRC_URI="http://wiki.qemu.org/download/${MY_P}-1.tar.bz2
- http://dev.gentoo.org/~lu_zero/distfiles/qemu-1.1.0-r1-patches.tar.xz"
+SRC_URI="http://wiki.qemu.org/download/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~lu_zero/distfiles/qemu-${PVR}-patches.tar.xz"
KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
S="${WORKDIR}/${MY_P}"
fi
@@ -79,6 +79,11 @@ src_prepare() {
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target || die
+ if [[ ${PV} != *9999 ]]; then
+ EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" epatch
+ fi
+
epatch_user
}