summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-12-19 15:24:47 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-12-19 15:24:47 +0000
commit51e395c0d7e0adc06f152f6fcd7968aaffa29114 (patch)
tree779888a0e8531d7bf216d3efd5c5afa1f0b8da16 /app-emulation
parentsome new formats have been added after ffmpeg 0.9 which mplayer trunk now req... (diff)
downloadgentoo-2-51e395c0d7e0adc06f152f6fcd7968aaffa29114.tar.gz
gentoo-2-51e395c0d7e0adc06f152f6fcd7968aaffa29114.tar.bz2
gentoo-2-51e395c0d7e0adc06f152f6fcd7968aaffa29114.zip
Bump to 0.0.3
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog8
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.0.3.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index d03b132f79db..ccc4e3f557ba 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/libvirt-glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.4 2011/11/18 19:19:50 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.5 2011/12/19 15:24:47 nirbheek Exp $
+
+*libvirt-glib-0.0.3 (19 Dec 2011)
+
+ 19 Dec 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +libvirt-glib-0.0.3.ebuild:
+ Bump to 0.0.3
18 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org> Manifest:
Redigest (previous commit didn't do what I expected).
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.0.3.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.0.3.ebuild
new file mode 100644
index 000000000000..03d079956d50
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.0.3.ebuild,v 1.1 2011/12/19 15:24:47 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 python
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.7
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ vala? ( dev-lang/vala:0.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="--disable-test-coverage
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}