summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2005-04-11 21:50:17 +0000
committerJoshua Kinard <kumba@gentoo.org>2005-04-11 21:50:17 +0000
commit3d46923dc5e317f2088f6042856044b59bc0e0b6 (patch)
treedcd6292684e8ebd1ffa8308b3f5f816801e321a5 /app-emulation
parentadded ~amd64 to KEYWORDS, fixes #87245 (diff)
downloadgentoo-2-3d46923dc5e317f2088f6042856044b59bc0e0b6.tar.gz
gentoo-2-3d46923dc5e317f2088f6042856044b59bc0e0b6.tar.bz2
gentoo-2-3d46923dc5e317f2088f6042856044b59bc0e0b6.zip
Package Move: formerly mips64emul; now gxemul. Bump to 0.3.1, and comment ebuild a little more.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/gxemul/ChangeLog11
-rw-r--r--app-emulation/gxemul/Manifest5
-rw-r--r--app-emulation/gxemul/files/digest-gxemul-0.3.11
-rw-r--r--app-emulation/gxemul/files/gxemul-0.3.1-mips64-crosscc-check.patch12
-rw-r--r--app-emulation/gxemul/gxemul-0.3.1.ebuild44
-rw-r--r--app-emulation/gxemul/metadata.xml10
6 files changed, 83 insertions, 0 deletions
diff --git a/app-emulation/gxemul/ChangeLog b/app-emulation/gxemul/ChangeLog
new file mode 100644
index 000000000000..e70e19a759ae
--- /dev/null
+++ b/app-emulation/gxemul/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emulation/gxemul
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.1 2005/04/11 21:50:17 kumba Exp $
+
+*gxemul-0.3.1 (11 Apr 2005)
+
+ 11 Apr 2005; Joshua Kinard <kumba@gentoo.org> +metadata.xml,
+ +files/gxemul-0.3.1-mips64-crosscc-check.patch, +gxemul-0.3.1.ebuild:
+ Package Move: formerly mips64emul; now gxemul. Bump to 0.3.1, and comment
+ ebuild a little more.
+
diff --git a/app-emulation/gxemul/Manifest b/app-emulation/gxemul/Manifest
new file mode 100644
index 000000000000..605d7f4d31c3
--- /dev/null
+++ b/app-emulation/gxemul/Manifest
@@ -0,0 +1,5 @@
+MD5 7cc3fb0d4e01b910cfefd56569262517 metadata.xml 426
+MD5 41b5984546ede0071f700190d1bf736b gxemul-0.3.1.ebuild 1121
+MD5 efcb9928c406c8111eba9552d4cde0ec ChangeLog 386
+MD5 5ff0b1ae88e5227f27ed31943c08cabe files/gxemul-0.3.1-mips64-crosscc-check.patch 652
+MD5 badfea94dec73ff3fcb92817b6b35398 files/digest-gxemul-0.3.1 65
diff --git a/app-emulation/gxemul/files/digest-gxemul-0.3.1 b/app-emulation/gxemul/files/digest-gxemul-0.3.1
new file mode 100644
index 000000000000..824c0da56146
--- /dev/null
+++ b/app-emulation/gxemul/files/digest-gxemul-0.3.1
@@ -0,0 +1 @@
+MD5 4dfa30708589ab06f20dc89b58b88917 gxemul-0.3.1.tar.gz 1051847
diff --git a/app-emulation/gxemul/files/gxemul-0.3.1-mips64-crosscc-check.patch b/app-emulation/gxemul/files/gxemul-0.3.1-mips64-crosscc-check.patch
new file mode 100644
index 000000000000..f5ba7f649aba
--- /dev/null
+++ b/app-emulation/gxemul/files/gxemul-0.3.1-mips64-crosscc-check.patch
@@ -0,0 +1,12 @@
+diff -Naurp gxemul-0.3.1.orig/configure gxemul-0.3.1/configure
+--- gxemul-0.3.1.orig/configure 2005-03-28 15:55:15.000000000 -0500
++++ gxemul-0.3.1/configure 2005-04-11 14:24:24.662918008 -0400
+@@ -1098,7 +1098,7 @@ if [ z$ENABLEMIPS = zYES ]; then
+ printf "Checking for a GNU cross-compiler for 64-bit MIPS... "
+ echo 'int f(int x) { return x; }' > _testprog.c
+
+- for MIPS_TRY in mips64-unknown-elf mips64-elf mips-unknown-elf64; do
++ for MIPS_TRY in mips64-unknown-elf mips64-elf mips-unknown-elf64 mips-unknown-linux-gnu mips-linux; do
+ printf '#!/bin/sh\n'$MIPS_TRY'-gcc _testprog.c -c\n' > _test.sh
+ chmod 755 _test.sh
+ rm -f _testprog.o
diff --git a/app-emulation/gxemul/gxemul-0.3.1.ebuild b/app-emulation/gxemul/gxemul-0.3.1.ebuild
new file mode 100644
index 000000000000..cfc598ec646b
--- /dev/null
+++ b/app-emulation/gxemul/gxemul-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.3.1.ebuild,v 1.1 2005/04/11 21:50:17 kumba Exp $
+
+inherit eutils
+
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
+HOMEPAGE="http://gavare.se/gxemul/"
+SRC_URI="http://gavare.se/gxemul/src/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
+IUSE="X cacheemu delays mips16"
+
+DEPEND="X? ( virtual/x11 )"
+
+src_compile() {
+ cd ${S}
+ local myconf=""
+
+ # Patch to let gxemul's configure script pick
+ # up mips64 cross-compilers
+ epatch ${FILESDIR}/${P}-mips64-crosscc-check.patch
+
+ # Based on USE, enable or disable some options
+ use X || myconf="${myconf} --disable-x"
+ use cacheemu && myconf="${myconf} --enable-caches"
+ use delays && myconf="${myconf} --enable-delays"
+ use mips16 && myconf="${myconf} --enable-mips16"
+
+ echo -e ""
+ einfo "Configuring with: ${myconf}"
+ ./configure ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin gxemul || die "gxemul not found in ${S}"
+ doman man/*.1
+ dodoc BUGS HISTORY LICENSE README RELEASE TODO
+ dohtml doc/*
+}
diff --git a/app-emulation/gxemul/metadata.xml b/app-emulation/gxemul/metadata.xml
new file mode 100644
index 000000000000..aa5d83c18ec4
--- /dev/null
+++ b/app-emulation/gxemul/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>kumba@gentoo.org</email>
+ <name>Joshua Kinard</name>
+ </maintainer>
+ <herd>no-herd</herd>
+ <longdescription>Machine Emulator. Supports emulation across several architectures. Primarily for MIPS support, but other platform support coming soon.</longdescription>
+</pkgmetadata>