summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-02-16 12:05:58 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-02-16 12:05:58 +0000
commit199db702fb1c5e226bfdca875caf9e77f7e3e921 (patch)
tree46a8c68ada8159f860e92d86a912080292a54f29 /app-emulation
parentStable for amd64, wrt bug #403935 (diff)
downloadgentoo-2-199db702fb1c5e226bfdca875caf9e77f7e3e921.tar.gz
gentoo-2-199db702fb1c5e226bfdca875caf9e77f7e3e921.tar.bz2
gentoo-2-199db702fb1c5e226bfdca875caf9e77f7e3e921.zip
Security bump. #404071
Add desktop file for jcontrol using relative path for icon. #403139 Use java-vm-2 eclass to apply PaX markings. (Portage version: 2.1.10.45/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog12
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.31.ebuild104
2 files changed, 114 insertions, 2 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index 534092a9c6a1..74dba8c869c2 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/emul-linux-x86-java
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.107 2011/11/05 21:34:26 caster Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.108 2012/02/16 12:05:58 sera Exp $
+
+*emul-linux-x86-java-1.6.0.31 (16 Feb 2012)
+
+ 16 Feb 2012; Ralph Sennhauser <sera@gentoo.org>
+ +emul-linux-x86-java-1.6.0.31.ebuild:
+ Security bump. #404071
+ Add desktop file for jcontrol using relative path for icon. #403139
+ Use java-vm-2 eclass to apply PaX markings.
05 Nov 2011; Vlastimil Babka <caster@gentoo.org>
-emul-linux-x86-java-1.6.0.26.ebuild, -emul-linux-x86-java-1.6.0.27.ebuild,
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.31.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.31.ebuild
new file mode 100644
index 000000000000..20ce89eceb68
--- /dev/null
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.31.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.31.ebuild,v 1.1 2012/02/16 12:05:58 sera Exp $
+
+EAPI="4"
+
+inherit java-vm-2 eutils prefix versionator
+
+# This URIs need to be updated when bumping!
+JRE_URI="http://www.oracle.com/technetwork/java/javase/downloads/jre-6u31-download-1501637.html"
+
+MY_PV="$(get_version_component_range 2)u$(get_version_component_range 4)"
+S_PV="$(replace_version_separator 3 '_')"
+
+X86_AT="jre-${MY_PV}-linux-i586.bin"
+
+DESCRIPTION="Oracle's Java SE Runtime Environment (32bit)"
+HOMEPAGE="http://www.oracle.com/technetwork/java/javase/"
+SRC_URI="${X86_AT}"
+
+LICENSE="Oracle-BCLA-JavaSE"
+SLOT="1.6"
+KEYWORDS="-* ~amd64"
+IUSE="X alsa nsplugin"
+
+RESTRICT="fetch strip"
+QA_TEXTRELS="
+ opt/${P}/lib/i386/client/libjvm.so
+ opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/server/libjvm.so"
+
+RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
+ X? ( app-emulation/emul-linux-x86-xlibs )"
+
+S="${WORKDIR}/jre${S_PV}"
+
+pkg_nofetch() {
+ einfo "Due to Oracle no longer providing the distro-friendly DLJ bundles, the package has become fetch restricted again."
+ einfo ""
+ einfo "Please download ${X86_AT} from:"
+ einfo "${JRE_URI}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ sh "${DISTDIR}"/${A} -noregister || die "Failed to unpack"
+}
+
+src_compile() {
+ # This needs to be done before CDS - #215225
+ java-vm_set-pax-markings "${S}"
+
+ # see bug #207282
+ einfo "Creating the Class Data Sharing archives"
+ bin/java -client -Xshare:dump || die
+ bin/java -server -Xshare:dump || die
+}
+
+src_install() {
+ # We should not need the ancient plugin for Firefox 2 anymore, plus it has
+ # writable executable segments
+ rm -vf lib/i386/libjavaplugin_oji.so \
+ lib/i386/libjavaplugin_nscp*.so
+ rm -vrf plugin/i386
+ # Without nsplugin flag, also remove the new plugin
+ arch=i386;
+ if ! use nsplugin; then
+ rm -vf lib/${arch}/libnpjp2.so \
+ lib/${arch}/libjavaplugin_jni.so
+ fi
+
+ dodir /opt/${P}
+ cp -pPR bin lib man "${ED}"/opt/${P} || die
+
+ # Remove empty dirs we might have copied
+ rmdir -v $(find "${D}" -type d -empty) || die
+
+ dodoc COPYRIGHT README
+
+ if use nsplugin; then
+ install_mozilla_plugin /opt/${P}/lib/${arch}/libnpjp2.so
+ fi
+
+ # Install desktop file for the Java Control Panel.
+ # Using ${PN}-${SLOT} to prevent file collision with jre and or other slots.
+ # make_desktop_entry can't be used as ${P} would end up in filename.
+ newicon lib/desktop/icons/hicolor/48x48/apps/sun-jcontrol.png \
+ sun-jcontrol-${PN}-${SLOT}.png || die
+ sed -e "s#Name=.*#Name=Java Control Panel for Oracle JDK ${SLOT} (${PN})#" \
+ -e "s#Exec=.*#Exec=/opt/${P}/bin/jcontrol#" \
+ -e "s#Icon=.*#Icon=sun-jcontrol-${PN}-${SLOT}.png#" \
+ lib/desktop/applications/sun_java.desktop > \
+ "${T}"/jcontrol-${PN}-${SLOT}.desktop || die
+ domenu "${T}"/jcontrol-${PN}-${SLOT}.desktop
+
+ # bug #56444
+ cp "${FILESDIR}"/fontconfig.Gentoo.properties "${T}"/fontconfig.properties || die
+ eprefixify "${T}"/fontconfig.properties
+ insinto /opt/${P}/lib/
+ doins "${T}"/fontconfig.properties
+
+ set_java_env "${FILESDIR}/${VMHANDLE}.env-r1"
+ java-vm_revdep-mask
+}