summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-02-24 21:49:11 +0000
committerTilman Klar <phoenix@gentoo.org>2003-02-24 21:49:11 +0000
commiteb1ff8256f718b7e1d99d213161a04fe764e78f6 (patch)
tree6631311e12c9c38b2948d47815bdfd04365cf682 /app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
parentsame as before (diff)
downloadgentoo-2-eb1ff8256f718b7e1d99d213161a04fe764e78f6.tar.gz
gentoo-2-eb1ff8256f718b7e1d99d213161a04fe764e78f6.tar.bz2
gentoo-2-eb1ff8256f718b7e1d99d213161a04fe764e78f6.zip
Updated the ebuild (no revision bump).
Diffstat (limited to 'app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild')
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild31
1 files changed, 11 insertions, 20 deletions
diff --git a/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild b/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
index 703a74497ea9..35b6cd3a46f9 100644
--- a/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
+++ b/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild,v 1.1 2003/02/18 16:15:56 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild,v 1.2 2003/02/24 21:49:11 phoenix Exp $
IUSE="cups opengl"
-P="winex-${PV}"
-SRC_URI="${P}.tgz"
+MY_P="winex-${PV}"
DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
HOMEPAGE="http://www.transgaming.com/"
SLOT="0"
-KEYWORDS="~x86"
-LICENSE="Transgaming"
+KEYWORDS="x86"
+LICENSE="Aladdin"
RDEPEND="virtual/x11
opengl? ( virtual/opengl )
@@ -21,30 +20,24 @@ RDEPEND="virtual/x11
!app-emulation/winex"
src_unpack () {
-
- if [ ! -e "${DISTDIR}/${P}.tgz" ] ; then
+ if [ ! -e "${DISTDIR}/${MY_P}.tgz" ] ; then
eerror ""
- eerror "Please download the appropriate WineX archive (${P}.tgz)"
+ eerror "Please download the appropriate WineX archive (${MY_P}.tgz)"
eerror "from: ${HOMEPAGE} (requires a Transgaming subscription)."
eerror ""
eerror "The archive should be placed into ${DISTDIR}."
- die "package archive (${P}.tgz) not found"
- fi
-
- mkdir ${S}
- tar -C ${S} -xzf ${DISTDIR}/${P}.tgz
+ eerror ""
+ die "package archive (${MY_P}.tgz) not found"
+ fi
+ unpack "${MY_P}.tgz"
}
src_install () {
-
- mv ${S}/usr ${D}
-
+ mv "${WORKDIR}/usr" "${D}"
}
pkg_postinst() {
-
- einfo ""
einfo "Run /usr/bin/winex to start winex as any non-root user."
einfo "This is a wrapper-script which will take care of creating"
einfo "an initial environment and do everything else."
@@ -64,6 +57,4 @@ pkg_postinst() {
einfo "Note: Binaries will still need excecutable permissions to run."
einfo "Note: If binfmt_misc is compiled as a module, make sure you"
einfo "have it loaded on startup by adding it to /etc/modules.autoload."
- einfo ""
-
}