summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-02-18 16:15:56 +0000
committerTilman Klar <phoenix@gentoo.org>2003-02-18 16:15:56 +0000
commit6cb08bbc8109ceffe2922c9cea7854769454ff45 (patch)
tree5fbf8ede2826a58c9604816e44a217546a077767 /app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
parentMasking app-emulation/winex-transgaming because i'm unable to test it (i'm no... (diff)
downloadgentoo-2-6cb08bbc8109ceffe2922c9cea7854769454ff45.tar.gz
gentoo-2-6cb08bbc8109ceffe2922c9cea7854769454ff45.tar.bz2
gentoo-2-6cb08bbc8109ceffe2922c9cea7854769454ff45.zip
Adding new package to the tree: winex-transgaming. See bug #11023 for further details.
Diffstat (limited to 'app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild')
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild b/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
new file mode 100644
index 000000000000..703a74497ea9
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild,v 1.1 2003/02/18 16:15:56 phoenix Exp $
+
+IUSE="cups opengl"
+
+P="winex-${PV}"
+SRC_URI="${P}.tgz"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="Transgaming"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex"
+
+src_unpack () {
+
+ if [ ! -e "${DISTDIR}/${P}.tgz" ] ; then
+ eerror ""
+ eerror "Please download the appropriate WineX archive (${P}.tgz)"
+ eerror "from: ${HOMEPAGE} (requires a Transgaming subscription)."
+ eerror ""
+ eerror "The archive should be placed into ${DISTDIR}."
+ die "package archive (${P}.tgz) not found"
+ fi
+
+ mkdir ${S}
+ tar -C ${S} -xzf ${DISTDIR}/${P}.tgz
+
+}
+
+src_install () {
+
+ mv ${S}/usr ${D}
+
+}
+
+pkg_postinst() {
+
+ einfo ""
+ einfo "Run /usr/bin/winex to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+ einfo ""
+
+}