summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Veber <coronalvr@gentoo.org>2003-06-24 18:41:14 +0000
committerAlex Veber <coronalvr@gentoo.org>2003-06-24 18:41:14 +0000
commit2ecc1b2e67bbbaf6a980d203b9d2f5b4872dea7e (patch)
tree77b722eb5d20f0adfcff8255d0123c73d36a7e2e /app-emulation/winex-cvs
parentversion bump. (diff)
downloadgentoo-2-2ecc1b2e67bbbaf6a980d203b9d2f5b4872dea7e.tar.gz
gentoo-2-2ecc1b2e67bbbaf6a980d203b9d2f5b4872dea7e.tar.bz2
gentoo-2-2ecc1b2e67bbbaf6a980d203b9d2f5b4872dea7e.zip
version bump.
Diffstat (limited to 'app-emulation/winex-cvs')
-rw-r--r--app-emulation/winex-cvs/ChangeLog7
-rw-r--r--app-emulation/winex-cvs/Manifest4
-rw-r--r--app-emulation/winex-cvs/files/digest-winex-cvs-3.10
-rw-r--r--app-emulation/winex-cvs/winex-cvs-3.1.ebuild143
4 files changed, 151 insertions, 3 deletions
diff --git a/app-emulation/winex-cvs/ChangeLog b/app-emulation/winex-cvs/ChangeLog
index a6dc82525abe..c4e6e2d91eb3 100644
--- a/app-emulation/winex-cvs/ChangeLog
+++ b/app-emulation/winex-cvs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/winex-cvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.13 2003/06/15 18:31:25 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.14 2003/06/24 18:40:53 coronalvr Exp $
+
+*winex-cvs-3.1 (24 Jun 2003)
+
+ 24 Jun 2003; Alex Veber <coronalvr@gentoo.org> winex-cvs-3.1.ebuild:
+ version bump.
15 Jun 2003; Martin Holzer <mholzer@gentoo.org> winex-cvs-3.0.ebuild:
Added wine.conf man page to be installed. Closes #22848.
diff --git a/app-emulation/winex-cvs/Manifest b/app-emulation/winex-cvs/Manifest
index b215bafe134f..4de73e8e1b59 100644
--- a/app-emulation/winex-cvs/Manifest
+++ b/app-emulation/winex-cvs/Manifest
@@ -1,7 +1,7 @@
-MD5 9479c013a2ef1ad461594f972237a543 winex-cvs-3.1.ebuild 4277
+MD5 3711d6142994356772611b47413366fe winex-cvs-3.1.ebuild 4279
MD5 a72aff1af2fed78b4d9bfd663f2bb1b4 winex-cvs-2.2.1.ebuild 4012
MD5 9479c013a2ef1ad461594f972237a543 winex-cvs-3.0.ebuild 4277
-MD5 7e479cb96584996722e7639cf0d885c2 ChangeLog 4692
+MD5 4c6bf0d441d1ff5b77023cf2e7898537 ChangeLog 4812
MD5 dcdbcea3b1e30203a037de864aee829d files/winex-cvs-fake_windows.tar.bz2 546
MD5 6b63a4e1f7384c6dbb53e53f09198665 files/winex-cvs-regedit 516
MD5 a0f00bd1db2d0bc928d3845f4aac078a files/winex-cvs-winex 1244
diff --git a/app-emulation/winex-cvs/files/digest-winex-cvs-3.1 b/app-emulation/winex-cvs/files/digest-winex-cvs-3.1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emulation/winex-cvs/files/digest-winex-cvs-3.1
diff --git a/app-emulation/winex-cvs/winex-cvs-3.1.ebuild b/app-emulation/winex-cvs/winex-cvs-3.1.ebuild
new file mode 100644
index 000000000000..c7475429b492
--- /dev/null
+++ b/app-emulation/winex-cvs/winex-cvs-3.1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-3.1.ebuild,v 1.1 2003/06/24 18:40:53 coronalvr Exp $
+
+IUSE="cups opengl"
+
+inherit eutils
+
+# Dont modify the ECVS_BRANCH setting yourself.
+# Instead, make a backup of this ebuild and rename it to
+# winex-[your branch].ebuild.
+#
+# Example:
+# winex-kohan-2.1.ebuild
+#
+# You can find more branches on
+# http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/winex/wine/
+
+
+ECVS_SERVER="cvs.winex.sourceforge.net:/cvsroot/winex"
+ECVS_MODULE="wine"
+ECVS_BRANCH=${PN/cvs/}${PV//./-}
+ECVS_BRANCH=${ECVS_BRANCH/pre/pre-}
+ECVS_BRANCH=${ECVS_BRANCH/_/-}
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${ECVS_BRANCH}"
+
+inherit cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+#echo ${ECVS_BRANCH}
+
+
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming.
+ This ebuild will fetch the newest cvs sources from the cvs-server."
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="0"
+KEYWORDS="x86 -ppc"
+LICENSE="Aladdin"
+
+newdepend "sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11
+ dev-lang/tcl
+ dev-lang/tk )
+ opengl? ( virtual/opengl )
+ cups? ( net-print/cups )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+
+ # patching winex to not compile wcmd
+ epatch ${FILESDIR}/winex-cvs-3.0_pre1.patch
+
+ # the folks at #winehq were really angry about custom optimization
+ unset CFLAGS
+ unset CXXFLAGS
+
+ ./configure --prefix=/usr/lib/winex-cvs \
+ --sysconfdir=/etc/winex-cvs \
+ --host=${CHOST} \
+ --enable-curses \
+ --with-x \
+ ${myconf} || die "configure failed"
+
+ # Fixes a winetest issue
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # This persuades wineshelllink that "winex-cvs" is a better loader :)
+ cd ${S}/tools
+ cp wineshelllink 1
+ sed -e 's/\(WINE_LOADER=\)\(\${WINE_LOADER:-wine}\)/\1winex-cvs/' 1 > wineshelllink
+
+ cd ${S}
+ make depend all || die "make depend all failed"
+ cd programs && gmake || die "emake died"
+}
+
+src_install () {
+ local WINEXMAKEOPTS="prefix=${D}/usr/lib/winex-cvs"
+
+ # Installs winex to /usr/lib/winex-cvs
+ cd ${S}
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+ cd ${S}/programs
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+
+
+ # Creates /usr/lib/winex-cvs/.data with fake_windows in it
+ # This is needed for our new winex-cvs wrapper script
+ dodir /usr/lib/winex-cvs/.data
+ pushd ${D}/usr/lib/winex-cvs/.data
+ tar jxvf ${FILESDIR}/${PN}-fake_windows.tar.bz2
+ popd
+ cp ${S}/documentation/samples/config ${S}/documentation/samples/config.orig
+ sed -e 's/.transgaming\/c_drive/.winex-cvs\/fake_windows/' \
+ ${S}/documentation/samples/config.orig > ${S}/documentation/samples/config
+ cp ${S}/documentation/samples/config ${D}/usr/lib/winex-cvs/.data/config
+ cp ${WORKDIR}/wine/winedefault.reg ${D}/usr/lib/winex-cvs/.data/winedefault.reg
+ # Install the wrapper script
+ dodir /usr/bin
+ cp ${FILESDIR}/${PN}-winex ${D}/usr/bin/winex-cvs
+ cp ${FILESDIR}/${PN}-regedit ${D}/usr/bin/regedit-winex-cvs
+
+ # Take care of the other stuff
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /usr/lib/winex-cvs/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/winex-cvs/bin
+ chmod a-x *.so
+
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/winex-cvs to start winex."
+ einfo "This is a wrapper-script which will take care of everything"
+ einfo "else. If you have further questions, enhancements or patches"
+ einfo "send an email to phoenix@gentoo.org"
+ einfo ""
+ einfo "Manpage has been installed to the system."
+ einfo "\"man winex-cvs\" should show it."
+}
+