summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-05-29 23:04:13 +0000
committerPeter Gavin <pete@gentoo.org>2001-05-29 23:04:13 +0000
commit38a2b6bcc7e801d8d0f2bfe9e9e9a6519a73e22e (patch)
tree4159925fcc9d7864fa5bff32d2e6abf8f062a490 /app-emulation/wine
parentUpdate ppp to version 2.4.1 (diff)
downloadgentoo-2-38a2b6bcc7e801d8d0f2bfe9e9e9a6519a73e22e.tar.gz
gentoo-2-38a2b6bcc7e801d8d0f2bfe9e9e9a6519a73e22e.tar.bz2
gentoo-2-38a2b6bcc7e801d8d0f2bfe9e9e9a6519a73e22e.zip
added wine-20010418, with winesetuptk which provides a simple tcl/tk based setup interface for wine; also added new tcl/tk package plus itcl which is required for winesetuptk. now I can play starcraft! :)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/files/digest-wine-200104182
-rw-r--r--app-emulation/wine/files/wine.env5
-rw-r--r--app-emulation/wine/wine-20010418.ebuild66
3 files changed, 73 insertions, 0 deletions
diff --git a/app-emulation/wine/files/digest-wine-20010418 b/app-emulation/wine/files/digest-wine-20010418
new file mode 100644
index 000000000000..d427e2ffdb4d
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20010418
@@ -0,0 +1,2 @@
+MD5 d773c35c57579ac78f8926c5a7f9a1ec Wine-20010418.tar.gz
+MD5 6fc1bce5da60f7fe8b96d8cac4845505 winesetuptk-0.5.1b.tar.gz
diff --git a/app-emulation/wine/files/wine.env b/app-emulation/wine/files/wine.env
new file mode 100644
index 000000000000..8710e8042d27
--- /dev/null
+++ b/app-emulation/wine/files/wine.env
@@ -0,0 +1,5 @@
+PATH=/opt/wine/bin
+ROOTPATH=/opt/wine/bin
+MANPATH=/opt/wine/man
+INFODIR=/opt/wine/info
+LDPATH=/opt/wine/lib
diff --git a/app-emulation/wine/wine-20010418.ebuild b/app-emulation/wine/wine-20010418.ebuild
new file mode 100644
index 000000000000..5a50ad26749e
--- /dev/null
+++ b/app-emulation/wine/wine-20010418.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20010418.ebuild,v 1.1 2001/05/29 23:04:13 pete Exp $
+
+WSV=0.5.1b
+A="Wine-${PV}.tar.gz winesetuptk-${WSV}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/${A}
+ http://twine.codeweavers.com/~mpilka/winesetuptk/winesetuptk-${WSV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/
+ http://wine.codeweavers.com/winesetuptk.shtml"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=sys-libs/ncurses-5.2
+ opengl? ( virtual/opengl )"
+
+RDEPEND="${DEPEND}
+ >=dev-lang/tcl-tk-8.4.2
+ >=dev-tcltk/itcl-3.2"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+ if [ "`use opengl`" ]
+ then
+ myconf="--enable-opengl"
+ else
+ myconf="--disable-opengl"
+ fi
+ try ./configure --prefix=/opt/wine --sysconfdir=/etc/opt/wine \
+ --host=${CHOST} ${myconf}
+
+ try make depend
+ try make
+
+ cd ${WORKDIR}/winesetuptk-${WSV}
+ ./configure --prefix=/opt/wine --with-launcher=/opt/wine/bin \
+ --with-data=/opt/wine/share/winesetuptk --with-doc=/opt/wine/share/doc/winesetuptk
+}
+
+src_install () {
+
+ try make prefix=${D}/opt/wine install
+ insinto /etc/opt/wine
+ doins ${FILESDIR}/wine.conf
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE
+ dodoc README WARRANTY
+
+ cd ${WORKDIR}/winesetuptk-${WSV}
+ make PREFIX_BIN=${D}/opt/wine/bin \
+ PREFIX_SRC=${D}/opt/wine/share/winesetuptk \
+ PREFIX_DOC=${D}/opt/wine/share/doc/winesetuptk \
+ cw-install install
+ cd doc ; docinto winesetuptk-${WSV}
+ dodoc CHANGELOG.TXT LICENSE.TXT README.TXT
+ cd development_doc ; docinto winesetuptk-${WSV}/development_doc
+ dodoc CHANGELOG.TXT global_cfg_db_members.txt
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/wine.env 90wine
+}
+