summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-16 16:22:18 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-16 16:22:18 +0000
commit1555a2ff2106057ff3582c227458c58406da0ec5 (patch)
treed1ad1b31d5cef8ffb8635246e8bb8b1f2e53a018 /app-emulation/vice
parentremove kth-krb, as per bug #173354 (diff)
downloadgentoo-2-1555a2ff2106057ff3582c227458c58406da0ec5.tar.gz
gentoo-2-1555a2ff2106057ff3582c227458c58406da0ec5.tar.bz2
gentoo-2-1555a2ff2106057ff3582c227458c58406da0ec5.zip
Patch from David Leverton for bug #179315
(Portage version: 2.1.3_rc2)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog8
-rw-r--r--app-emulation/vice/files/digest-vice-1.21-r13
-rw-r--r--app-emulation/vice/files/vice-1.21-fullscreen.patch11
-rw-r--r--app-emulation/vice/vice-1.21-r1.ebuild96
4 files changed, 117 insertions, 1 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index deafed1e16cb..53a4b8116e2d 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vice
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.50 2007/05/22 00:01:14 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.51 2007/06/16 16:22:18 nyhm Exp $
+
+*vice-1.21-r1 (16 Jun 2007)
+
+ 16 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/vice-1.21-fullscreen.patch, +vice-1.21-r1.ebuild:
+ Patch from David Leverton for bug #179315
21 May 2007; Tristan Heaven <nyhm@gentoo.org> vice-1.21.ebuild:
Add resid USE flag, bug #177102
diff --git a/app-emulation/vice/files/digest-vice-1.21-r1 b/app-emulation/vice/files/digest-vice-1.21-r1
new file mode 100644
index 000000000000..0c87a06f1327
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.21-r1
@@ -0,0 +1,3 @@
+MD5 913bdee9d59d154ed33ef4e037d8a12c vice-1.21.tar.gz 5725833
+RMD160 1384cb4d80be6801de603c0424b3a5e5dd18de15 vice-1.21.tar.gz 5725833
+SHA256 511ed35e6692f68e8b58ea3d040af6428239859e31eef9d99b6187a166373389 vice-1.21.tar.gz 5725833
diff --git a/app-emulation/vice/files/vice-1.21-fullscreen.patch b/app-emulation/vice/files/vice-1.21-fullscreen.patch
new file mode 100644
index 000000000000..2807331ff253
--- /dev/null
+++ b/app-emulation/vice/files/vice-1.21-fullscreen.patch
@@ -0,0 +1,11 @@
+--- vice-1.21/src/video.h~ 2006-06-11 23:23:36.000000000 +0100
++++ vice-1.21/src/video.h 2007-05-13 17:20:09.000000000 +0100
+@@ -78,7 +78,7 @@
+ };
+ typedef struct cap_render_s cap_render_t;
+
+-#define FULLSCREEN_MAXDEV 3
++#define FULLSCREEN_MAXDEV 4
+
+ struct cap_fullscreen_s {
+ unsigned int device_num;
diff --git a/app-emulation/vice/vice-1.21-r1.ebuild b/app-emulation/vice/vice-1.21-r1.ebuild
new file mode 100644
index 000000000000..6e7e30c8ebf6
--- /dev/null
+++ b/app-emulation/vice/vice-1.21-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.21-r1.ebuild,v 1.1 2007/06/16 16:22:18 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://www.viceteam.org/"
+SRC_URI="http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE="Xaw3d alsa arts esd ffmpeg gnome nls png readline resid sdl"
+
+RDEPEND="media-libs/giflib
+ media-libs/jpeg
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXv
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ x11-apps/xset
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ esd? ( media-sound/esound )
+ ffmpeg? (
+ media-video/ffmpeg
+ media-sound/lame
+ )
+ gnome? ( gnome-base/libgnomeui )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng )
+ readline? ( sys-libs/readline )
+ resid? ( media-libs/resid )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir
+ x11-proto/xproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/videoproto
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^gnulocaledir/s:$(prefix):/usr:' \
+ po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+ sed -i \
+ -e 's/getline/intlpo_getline/' \
+ po/intl2po.c \
+ || die "sed intl2po.c failed"
+ sed -i \
+ -e 's:\<SYNC\>:OPENGL_SYNC:g' \
+ configure src/arch/unix/x11/Makefile.in \
+ || die "sed configure failed"
+ epatch "${FILESDIR}"/${P}-uicolor.patch #174056
+ epatch "${FILESDIR}"/${P}-fullscreen.patch #179315
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-fullscreen \
+ --without-midas \
+ $(use_enable ffmpeg) \
+ $(use_enable gnome gnomeui) \
+ $(use_enable nls) \
+ $(use_with Xaw3d xaw3d) \
+ $(use_with alsa) \
+ $(use_with arts) \
+ $(use_with esd) \
+ $(use_with png) \
+ $(use_with readline) \
+ $(use_with resid) \
+ $(use_with sdl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FEEDBACK README
+ prepgamesdirs
+}