summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-04 20:05:05 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-04 20:05:05 +0000
commit05f78ff8d8919ec48894d9eac9def0124609170c (patch)
tree911d2495c43ad1d85974d05471023518c94a67ab /app-emulation/uae/uae-0.8.25_pre20040302.ebuild
parentInitial import (Manifest recommit) (diff)
downloadgentoo-2-05f78ff8d8919ec48894d9eac9def0124609170c.tar.gz
gentoo-2-05f78ff8d8919ec48894d9eac9def0124609170c.tar.bz2
gentoo-2-05f78ff8d8919ec48894d9eac9def0124609170c.zip
Version bump
Diffstat (limited to 'app-emulation/uae/uae-0.8.25_pre20040302.ebuild')
-rw-r--r--app-emulation/uae/uae-0.8.25_pre20040302.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
new file mode 100644
index 000000000000..c4db6b94b086
--- /dev/null
+++ b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.1 2004/03/04 20:05:05 dholm Exp $
+
+inherit flag-o-matic
+
+MY_PV="0.8.25-20040302"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="The Umiquious Amiga Emulator"
+HOMEPAGE="http://www.rcdrummond.net/uae/"
+SRC_URI="http://www.rcdrummond.net/uae/uae-${MY_PV}/uae-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="X gtk sdl"
+
+DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
+ ( ncurses? sys-libs/ncurses svga? media-libs/svgalib )
+ sdl? media-libs/libsdl
+ games-emulation/caps
+ app-cdr/cdrtools"
+
+src_compile() {
+ ewarn "Compiling the CPU-core requires a substantial amount of RAM."
+ ewarn "Make sure that you have at least 512MB of RAM+SWAP available."
+
+ # copy over dirty scsi copy script
+ cp ${FILESDIR}/install_libscg_gentoo ${S}/src
+ # and run
+ /bin/sh ${S}/src/install_libscg_gentoo
+
+ replace-flags "-O3" "-O2"
+ use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
+
+ econf ${myconf} \
+ --enable-threads \
+ --enable-scsi-device \
+ --enable-cdtv \
+ --enable-cd32 \
+ || die "./configure failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ cp docs/unix/README docs/README.unix
+ dodoc docs/COMPATIBILITY docs/CREDITS docs/FAQ docs/NEWS \
+ docs/README docs/README.PROGRAMMERS docs/README.unix \
+ docs/translated/*
+
+ emake install DESTDIR=${D}
+
+ insinto /usr/share/uae/amiga-tools
+ doins amiga/{*hack,trans*,uae*,*.library}
+}