summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-01-12 22:03:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-01-12 22:03:01 +0000
commit91e94195f0f4702ac524b26303fdefe2fff74b5f (patch)
tree029a7f0683cfb4334d80697c1f30de77da772582 /app-emulation/simh
parentBump to 2.0.17. Translation updates. (diff)
downloadgentoo-2-91e94195f0f4702ac524b26303fdefe2fff74b5f.tar.gz
gentoo-2-91e94195f0f4702ac524b26303fdefe2fff74b5f.tar.bz2
gentoo-2-91e94195f0f4702ac524b26303fdefe2fff74b5f.zip
Fix patch to unpack and compile.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-emulation/simh')
-rw-r--r--app-emulation/simh/ChangeLog6
-rw-r--r--app-emulation/simh/files/simh-3.7.0-asneeded.patch4
-rw-r--r--app-emulation/simh/simh-3.7.0.ebuild6
3 files changed, 9 insertions, 7 deletions
diff --git a/app-emulation/simh/ChangeLog b/app-emulation/simh/ChangeLog
index 157df2c639db..1a06b64b4f19 100644
--- a/app-emulation/simh/ChangeLog
+++ b/app-emulation/simh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/simh
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.9 2009/01/04 14:40:35 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.10 2009/01/12 22:03:01 flameeyes Exp $
+
+ 12 Jan 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ files/simh-3.7.0-asneeded.patch, simh-3.7.0.ebuild:
+ Fix patch to unpack and compile.
04 Jan 2009; Christoph Mende <angelos@gentoo.org>
+files/simh-3.7.0-asneeded.patch, simh-3.7.0.ebuild:
diff --git a/app-emulation/simh/files/simh-3.7.0-asneeded.patch b/app-emulation/simh/files/simh-3.7.0-asneeded.patch
index fd64bbbfdff5..804606a55f26 100644
--- a/app-emulation/simh/files/simh-3.7.0-asneeded.patch
+++ b/app-emulation/simh/files/simh-3.7.0-asneeded.patch
@@ -4,8 +4,8 @@
else
OS_CCDEFS = -D_GNU_SOURCE
endif
--CC = x86_64-pc-linux-gnu-gcc -std=c99 -march=native -Os -pipe -U__STRICT_ANSI__ -lm -lrt $(OS_CCDEFS) -I .
-+CC = x86_64-pc-linux-gnu-gcc -std=c99 -march=native -Os -pipe -U__STRICT_ANSI__ $(OS_CCDEFS) -I .
+-CC = gcc -std=c99 -O2 -U__STRICT_ANSI__ -g -lm -lrt $(OS_CCDEFS) -I .
++CC := $(CC) -std=c99 -U__STRICT_ANSI__ $(OS_CCDEFS) -I. $(CFLAGS)
+LIBS = -lm -lrt
ifeq ($(USE_NETWORK),)
else
diff --git a/app-emulation/simh/simh-3.7.0.ebuild b/app-emulation/simh/simh-3.7.0.ebuild
index 22ec46d115d4..c45d92bdeb5e 100644
--- a/app-emulation/simh/simh-3.7.0.ebuild
+++ b/app-emulation/simh/simh-3.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.7.0.ebuild,v 1.4 2009/01/04 14:40:35 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.7.0.ebuild,v 1.5 2009/01/12 22:03:01 flameeyes Exp $
inherit eutils toolchain-funcs versionator
@@ -29,14 +29,12 @@ src_unpack() {
# convert makefile from dos format to unix format
edos2unix makefile
- sed -i -e "s:gcc:$(tc-getCC):" \
- -e "s: -g::" \
- -e "s:-O2:${CFLAGS}:" makefile
epatch "${FILESDIR}/makefile.patch" \
"${FILESDIR}"/${P}-asneeded.patch
}
src_compile() {
+ tc-export CC
emake || die "make failed"
}